Opened 10 years ago

Closed 10 years ago

#4126 closed Bug (worksforme)

config dir from 2.21 freezes T

Reported by: ZogG Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.22
Severity: Normal Keywords: lock
Cc: pva@…

Description

Just updated on gentoo T top 2.22 from 2.21 and it started and 1 one seconded freezed up. Using gtk version: Installed versions: 2.22(10:40:52 PM 03/12/2011)(gtk libnotify -gnome -kde -libcanberra -qt4)

after cleaning ~/.config/transmission it starts well. So i played with files and got them back in config dir one by one. And found out it starts well without old lock file.

i would duplicate bug on gentoo bugzilla as well.

Change History (19)

comment:1 Changed 10 years ago by mithodin

I can confirm this bug on gentoo with USE="gtk libnotify qt4 -gnome -kde -libcanberra" using transmission-gtk. transmission-qt, however, works just fine.

From my testing, the problem seems to be unfinished torrents, because starting transmission-gtk clean (rm ~/.config/transmission/torrents/* ~/.config/transmission/resume/*), things work pretty well (I can download a whole torrent).

Also, .torrents with whitespaces in their names seem to trigger a freeze (using transmission-gtk).

comment:2 Changed 10 years ago by pva0xd

  • Cc pva@… added

comment:3 Changed 10 years ago by jordan

I'm not seeing this behavior.

Could you walk me through the steps I would need to trigger this?

What I tried was starting with a clear configuration in 2.21, exiting, and then using the same config dir on a trunk build of the pre-2.30 code.

comment:4 Changed 10 years ago by pva0xd

https://bugs.gentoo.org/show_bug.cgi?id=359163#c10

Another user and he reports that deletion of ~/.config/transmission/resume/* helped to workaround freeze. May be this helps to get an idea of what's going on...

comment:5 Changed 10 years ago by jordan

Thank you for that link, but it doesn't really answer my quesiton.

I'm not seeing this behavior. Could you walk me through the steps I would need to trigger this?

comment:6 Changed 10 years ago by ZogG

I just used transmission since 0.xx and had same configs, last upgrade to 2.22 caused me that gtk version launches and freezes. So i tried to use empty config dir and it worked fine. After i played with config dir, getting folder by folder and launching it again and again till i got all the torrents and configs back and no freezes.

comment:7 Changed 10 years ago by mithodin

Steps to reproduces (at least for me):

  1. Get a .torrent file
  2. Rename it (if not already the case) to something containing whitespaces and/or other non-alphanumeric characters (I'm pretty shure it's the whitespaces...)
  3. Add torrent to transmission-gtk
  4. Let it download for a while, then exit transmission
  5. Restart transmission
  6. Lay back and watch frozen transmission

comment:8 Changed 10 years ago by jordan

I'm not able to freeze Transmission with the steps listed in comment:7. I have dozens of torrents with spaces in the filename and am not seeing this issue.

comment:9 Changed 10 years ago by mithodin

Then it might be due to some other error. The problem never ocurred for me while using torrent files named only with alphanumerics, though. I might try to narrow it down a bit more when I get to it.

comment:10 Changed 10 years ago by driedfruit

Can confirm this on 2.12. Removing the .torrent/.resume file staring with a pound sign from the ~/.config/transmission/torrents and ~/.config/transmission/resume directories made the freeze go away. Returning said file there, or adding new torrents starting with a pound sign DOES NOT however bring the freeze back. In fact, since the fix, I was unable to reproduce the freeze no matter how hard I tried.

So while I can't give good reproduction steps (I'll try again), I can confirm ~/.config cleaning helps AND that non-alphanumeric torrent files are related.

comment:11 follow-up: Changed 10 years ago by pva0xd

jordan, could you provide some instructions for users who experience this issue on how to debug this issue? strace comes to mind, but may be something else?

comment:12 Changed 10 years ago by ZogG

i don't know if it's the same bug (if needed and not reported i can report it separetly) but as well it freezes while i close. Steps: file-> Quit T is showing the usual window while quiting and closes it but it still hangs in system tray and icon is not responsive, so it works only with killall transmission-gtk, it happens always. tried to start from console for more info but there is nothing there. Is there anyway i can provide more information?

comment:13 in reply to: ↑ 11 Changed 10 years ago by jordan

Replying to pva0xd:

jordan, could you provide some instructions for users who experience this issue on how to debug this issue? strace comes to mind, but may be something else?

I'd recommend running Transmission in gdb, then getting a backtrace when Transmission freezes:

$ gdb transmission-gtk
(gdb) handle SIGPIPE nostop noprint
(gdb) r
... run until Transmission freezes, then type ctrl-c to return control to the debugger
(gdb) thread apply all bt full

comment:14 Changed 10 years ago by jordan

Has anyone seeing this bug been able to get a gdb backtrace as described in comment:13?

comment:15 Changed 10 years ago by jordan

Has anyone seeing this bug been able to get a gdb backtrace as described in comment:13?

comment:16 Changed 10 years ago by pva0xd

Jordan, I've started stabilization of this package in Gentoo and in one-two week more/most users start to use it. If this problem is common I hope somebody reports backtrace or we'll have to clase both bugs as NEEDINFO and move forward

comment:17 Changed 10 years ago by jordan

Any news?

comment:18 Changed 10 years ago by pva0xd

No news. I've closed bug report in Gentoo as need info since transmission is already stable on 2.22 on x86 and amd64 and no information appeared.

comment:19 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket due to lack of information and inability to reproduce the problem.

If anyone has further information on this issue please post it here and reopen the ticket. Thanks!

Note: See TracTickets for help on using tickets.