Opened 10 years ago

Closed 4 years ago

#4129 closed Bug (duplicate)

Transmission does not catch torrents with overlapping files

Reported by: christuran Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.22
Severity: Normal Keywords:
Cc: computing@…

Description

Transmission does not notice if you add two different torrents with identically named files. If you start Torrent A, download the file, and then start Torrent B, transmission will happily overwrite the file.

How To Reproduce: Create two torrents with different contents but identically named files. Download them in succession or simultaneously.

Suggested Fix: Add a check for this either when the torrent is started or when it is added.

Change History (4)

comment:1 Changed 8 years ago by Windcheetah

  • Cc computing@… added

Hi, I'm running 2.77 (14031) GTK+ and have the same problem, from the Mint Repository.

I had 2 torrents downloading, what I assumed were different files. When the first one finished, I then "delete files and remove" to get rid of the part file and torrent, so I thought, but this then deleted the completed file as well.

comment:2 Changed 7 years ago by nipatriknilsson

There is a quick work-around here:

When you find a duplicated file and get an error, use set location to set a new location.

Better would be if transmission found the duplicated file and renamed it to the hash of the torrent like "dir/file-{hash}.txt" instead of overwriting "dir/file.txt"

Overwriting is a never ending loop if you select verify and resume when transmission detected a wrong checksum in a file.

comment:3 Changed 4 years ago by mike.dld

Duplicate of #3215.

comment:4 Changed 4 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.