Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#414 closed Bug (fixed)

Trouble with many opened files

Reported by: JlaMo Owned by: charles
Priority: High Milestone: 0.91
Component: libtransmission Version: 0.90
Severity: Major Keywords:
Cc:

Description

When Transmission 0.9 working more than 15-20 minutes, such error appears very frequently at message log: "Couldn't create socket (Too many opened files)", and I cant change tabs in Inspector (it freezes), open new .torrent files (Transmission haven't any reaction on drag'n'drop, File-Open and putting torrent to "Watch folder"), open Preferences and save logs from Message log (Transmission crashes immediately). Also speed is reducing more than 2 times. I have 20 transfers, about 70 files total.

Change History (9)

comment:1 Changed 14 years ago by livings124

  • Milestone changed from 0.91 to None Set

comment:2 Changed 14 years ago by charles

  • Milestone changed from None Set to 0.91

One file descriptor has been found and fixed in r3551. I think this is the error that caused this bug, but we'll probably need more users testing Transmission to be certain.

comment:3 Changed 14 years ago by charles

  • Owner changed from somebody to charles
  • Status changed from new to assigned

comment:4 Changed 14 years ago by charles

  • Component changed from Transmission to libtransmission

comment:5 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

There's a night and day difference in the number of open files T has after an overnight run now.

comment:6 Changed 14 years ago by mickbuddha

  • Resolution fixed deleted
  • Status changed from closed to reopened

Using r3785 I am getting similar issues. Although I am not seeing reduced speeds, I am seeing a flood of "Couldn't create socket (Too many opened files)" errors as well as random visual errors(the scroll bar like to randomly hide, inspector sometimes renders wacky, etc.) I have 155 seeding/79 paused torrents, totaling 234

comment:7 Changed 14 years ago by livings124

mickbuddha: Are you seeing this in current nightlies?

comment:8 Changed 14 years ago by livings124

  • Resolution set to fixed
  • Status changed from reopened to closed

comment:9 Changed 14 years ago by charles

"Couldn't create socket (Too many opened files)" is resolved in 0.96 and trunk. It appears to have been caused by creating too many tracker connections at the same time.

Note: See TracTickets for help on using tickets.