Opened 11 years ago

Last modified 8 years ago

#4141 assigned Bug

transmission-show --scrape option not working with udp trackers

Reported by: gunzip Owned by: jordan
Priority: Low Milestone: Sometime
Component: Utils Version: 2.30
Severity: Normal Keywords:
Cc: nikoli@…

Description

when using the utility "transmission-show --scrape" option with a udp-tracker torrent, the output returns..

udp://tracker.openbittorrent.com:80/scrape?info ... error: Unsupported protocol

Test Condition: Linux Debian, transmission-show 2.22+ (12211)

Change History (8)

comment:1 Changed 11 years ago by jordan

  • Milestone changed from None Set to Sometime
  • Status changed from new to assigned

comment:2 Changed 11 years ago by jordan

  • Priority changed from Normal to Low
  • Version changed from 2.22+ to 2.30

comment:3 Changed 10 years ago by lazybones

This tracker is also often listed as http:// sometimes in the same torrent it is listed as both http and udp =. This tracker is VERY common in public torrents since it is generally open and free to use.

comment:4 Changed 9 years ago by MPW

Still not fixed in transmission-show 2.73 (13592)

comment:5 Changed 9 years ago by Nikoli

  • Cc nikoli@… added

comment:6 Changed 8 years ago by cyberbat

Still not fixed in 2.82

comment:7 Changed 8 years ago by livings124

That's why it's still open...

comment:8 Changed 8 years ago by jordan

It's still not fixed because the libtransmission code to work with UDP trackers is built around requiring a tr_session, which doesn't really make sense in transmission-show.

So the libtransmission/announcer-* code probably needs to be refactored to be more independent, which is a lot of work for a low-priority ticket.

I'm not saying that it'll never get done; just explaining why it hasn't been done yet.

Patches are welcomed. ;)

Note: See TracTickets for help on using tickets.