Opened 11 years ago

Closed 11 years ago

#4150 closed Bug (wontfix)

>= 12204 broken on PPC

Reported by: m1b Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.22+
Severity: Normal Keywords:
Cc:

Description

While debugging #4090, I've discovered that [12204] causes a crash on ppc (looks like something jumped to null) regardless of whether it's a debug build from xpjets or a local release build. [12203] does not exhibit this problem.

I understand if this gets closed as wontfix since ppc support is being removed for 2.30, but I wanted to report it for compleness's sake.

Exception Type:  EXC_BAD_ACCESS (SIGBUS)
Exception Codes: KERN_PROTECTION_FAILURE at 0x0000000000000000
Crashed Thread:  1

Thread 1 Crashed:
0   org.m0k.transmission          	0x00066e88 tr_buildPath + 296
1   org.m0k.transmission          	0x00078830 tr_sessionInitImpl + 376
2   org.m0k.transmission          	0x000922e8 readFromPipe + 340
3   org.m0k.transmission          	0x000d9c70 event_base_loop + 2432
4   org.m0k.transmission          	0x000d9f20 event_base_dispatch + 16
5   org.m0k.transmission          	0x000920d8 libeventThreadFunc + 188
6   org.m0k.transmission          	0x00081f38 ThreadFunc + 32
7   libSystem.B.dylib             	0x9284b0d0 _pthread_start + 316

Change History (11)

comment:1 Changed 11 years ago by livings124

Can you post the whole crash log?

comment:3 Changed 11 years ago by m1b

Just tried upgrading to [12261] in an effort to verify the fix to #4153, but I still get this crash on launch. Any chance of getting this one fixed? Thanks.

comment:4 Changed 11 years ago by jordan

m1b, is there any way to run your build in gdb s.t. you can get a gdb backtrace? That assertion crash report isn't enough information to fix the crash with.

comment:5 Changed 11 years ago by m1b

I can try -- I don't have a toolchain on this machine, so I need to go find one and get gdb installed. Could you let me know precisely what you want me to do? I am not particularly gdb literate, so step by step would be appreciated.

comment:6 Changed 11 years ago by jordan

Well, if you're more comfortable with another tool that would be fine. What I'm wanting to find out is what arguments were passed into tr_buildPath() and what it's trying to do when it crashes... the "+296" in the crash report above doesn't really help much. :(

comment:7 Changed 11 years ago by m1b

I can offer the following:

Program received signal EXC_BAD_ACCESS, Could not access memory.
Reason: KERN_PROTECTION_FAILURE at address: 0x00000000

0x00096b10 in tr_buildPath (first_element=0x0) at utils.c:620

#0  0x00096b10 in tr_buildPath (first_element=0x0) at utils.c:620
#1  0x000a9c64 in tr_sessionInitImpl (vdata=0xbfffeec0) at session.c:685
#2  0x000d3d64 in readFromPipe (fd=4, eventType=2, veh=0x383c40) at trevent.c:192
#3  0x00137898 in event_persist_closure (base=0x387cc0, ev=0x387fd0) at event.c:1238
#4  0x00137330 in event_process_active_single_queue (base=0x387cc0, activeq=0x387e40) at event.c:1282
#5  0x00137b24 in event_process_active (base=0x387cc0) at event.c:1354
#6  0x001384cc in event_base_loop (base=0x387cc0, flags=0) at event.c:1550
#7  0x00137c10 in event_base_dispatch (event_base=0x387cc0) at event.c:1382
#8  0x000d40b0 in libeventThreadFunc (veh=0x383c40) at trevent.c:248
#9  0x000bd1a0 in ThreadFunc (_t=0x387c90) at platform.c:118
#10 0x9284b0d4 in _pthread_start ()

This is with [12294]

NB that I have to build on a different machine than the one gdb is on, so this is all fairly cumbersome.

comment:8 Changed 11 years ago by m1b

Adding http://pastebin.com/aiF2eab0 for completeness.

comment:9 Changed 11 years ago by livings124

m1b: Are you still seeing this issue on current nightlies? No one on Intel (or another OS) has reported this, so it is quite possible that this is a build issue for PPC.

comment:10 Changed 11 years ago by m1b

livings124: yes, i just repro'ed it with 12359. jordan and i did some remote debugging a week ago and were able to isolate the rough location of where the relevant var was getting clobbered, but we've had a v.hard time reconnecting to finish the bug hunt.

comment:11 Changed 11 years ago by livings124

  • Resolution set to wontfix
  • Status changed from new to closed

Based on further discussions, this seems to be a build issue with PPC with the current configuration. Since we're dropping PPC, there's really no reason to pursue this.

Note: See TracTickets for help on using tickets.