Opened 8 years ago

Closed 7 years ago

#4154 closed Bug (invalid)

Error message continues to show, preventing other status updates

Reported by: sambrightman Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.04+
Severity: Normal Keywords:
Cc:

Description

After moving the data I accidentally tried to play a torrent without first using Set Location. The torrent turns red and shows the error message about missing data as expected. However, changing the location fails to correct this error and prevents the status from updating - for example, clicking Verify Local Data does not show the "Waiting to verify" message or any updates once the verification is taking place.

Change History (10)

comment:1 Changed 8 years ago by livings124

What happens in 2.22 or a current nightly?

comment:2 Changed 8 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Please reopen with more info.

The code for this has changed since 2.04.

comment:3 Changed 7 years ago by sambrightman

  • Resolution invalid deleted
  • Status changed from closed to reopened

Still seeing this on 2.33. It is easy to reproduce:

  • move data file away (shows error status)
  • Set Location to the new location
  • Verify Local Data
  • status of file does not update after the verification is complete (i.e. error status is cleared). Normally would see "waiting to verify" and "verifying...".

comment:4 Changed 7 years ago by livings124

What about in 2.50?

comment:5 Changed 7 years ago by sambrightman

I'll wait for Ubuntu 12.04 beta, which will contain 2.50, and get back to you. Do you expect it to be fixed? This was marked invalid, not fixed.

comment:6 Changed 7 years ago by livings124

I'm not sure if this has changed, since I do not use the GTK version, but it's possible.

comment:7 Changed 7 years ago by x190

sambrightman: Just to double-check--are you correctly selecting the enclosing directory of the data not the data directory or file itself? Does "Verify Local Data" succeed? Does the error clear when you resume the transfer?

Even with the Mac Client, the error doesn't clear until you resume the transfer, however, the main window does show "Checking existing data" during the verify process.

comment:8 Changed 7 years ago by sambrightman

Yes, it does work in the end. However, you can't see what is happening. If you do not first initiate the error, the status is shown there.

comment:9 Changed 7 years ago by jordan

I'll wait for Ubuntu 12.04 beta, which will contain 2.50, and get back to you. Do you expect it to be fixed?

sambrightman, any news?

comment:10 Changed 7 years ago by livings124

  • Resolution set to invalid
  • Status changed from reopened to closed

sambrightman, please reopen with the requested information

Note: See TracTickets for help on using tickets.