Opened 7 years ago

Closed 7 years ago

#4157 closed Bug (fixed)

"transmission-remote -si" doesn't show alternate download speeds correctly

Reported by: hsn Owned by: jordan
Priority: Normal Milestone: 2.30
Component: Daemon Version: 2.22
Severity: Normal Keywords:
Cc:

Description

Current settings before changes are made

> transmission-remote -si
VERSION
  Daemon version: 2.22 (12099)

LIMITS
  Upload speed limit: 30.00 KiB/s  (Enabled limit: 30.00 KiB/s; Disabled turtle limit: 15.00 KiB/s)
  Download speed limit: 100.00 KiB/s  (Enabled limit: 100.00 KiB/s; Disabled turtle limit: 100.00 KiB/s)

Now lets set alternate download speed

> transmission-remote --alt-speed-downlimit 50
http://127.0.0.1:9091/transmission/rpc/ responded: "success"

> transmission-remote -si
VERSION
  Daemon version: 2.22 (12099)
LIMITS
  Upload speed limit: 30.00 KiB/s  (Enabled limit: 30.00 KiB/s; Disabled turtle limit: 15.00 KiB/s)
  Download speed limit: 100.00 KiB/s  (Enabled limit: 100.00 KiB/s; Disabled turtle limit: 100.00 KiB/s)

Limits not changed. Changing alternate upload speed works as expected

Change History (3)

comment:1 Changed 7 years ago by jordan

  • Component changed from Transmission to Daemon
  • Milestone changed from None Set to 2.30
  • Owner set to jordan
  • Status changed from new to assigned

confirmed

comment:2 Changed 7 years ago by jordan

  • Summary changed from Set alternate download limit from commandline fails to "transmission-remote -si" doesn't show alternate download speeds correctly

Looks like the changes are made, but are displayed wrong in -si

comment:3 Changed 7 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in trunk for 2.30 by r12265

Note: See TracTickets for help on using tickets.