Opened 10 years ago

Closed 10 years ago

#4158 closed Bug (fixed)

scraping trackers of form "announce.php?key=...." not reported correctly by transmission-remote

Reported by: gunzip Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.22+
Severity: Normal Keywords:
Cc:

Description

with certain private trackers of form, e.g.

http://some.tracker.com:80/announce.php?key=.....

transmission-remote -t ID --info-trackers always returns "Tracker had 0 seeders and 0 leechers" eventhough the torrent seems to be connecting and running fine. don't know if this is a real scrape error or just a reporting error.

the only common and consistent factor that i can see is the "announce.php?=key" thing. another private tracker without php works fine. in any event, this could be misleading for some users when judging the health or status of a torrent.

Change History (7)

comment:1 follow-up: Changed 10 years ago by jordan

Are you certain that the tracker is returning meaningful scrape numbers?

comment:2 in reply to: ↑ 1 Changed 10 years ago by gunzip

Replying to jordan:

Are you certain that the tracker is returning meaningful scrape numbers?

pretty sure, because when i run "transmission-show --scrape" on that torrent i always get a valid scrape response. i should add that there is no indication of scrape failure in the logfile or anywhere else.

as mentioned, the only common denominator i can see with this bug is announce.php?key= , so i thought there might be some parsing quirk. all other http and udp trackers work fine.

just ran another quick test:

tr-remote -it > Tracker had 0 seeders and 0 leechers
tr-show -s > 12 seeders, 2 leechers

transmission-daemon 2.22+ (12264)

comment:3 Changed 10 years ago by gunzip

using transmission-remote-cli.py i see the scrape report in real time, making it easier to follow:

Last scrape: 03/31/2011 11:05:38 AM (20 minutes ago)
Tracker knows: 0 seeds and 0 leeches
Next scrape: 03/31/2011 11:35:38 AM (in 10 minutes)

again there is no error reported, and in fact it schedules another scrape at the regular interval. on rare occasions the Tracker will momentarily flash what looks like valid numbers, but they are quickly cleared and i end up with 0 seeds and 0 leeches.

comment:4 follow-up: Changed 10 years ago by jordan

I've tried several trackers that have announce URLs of the form you're describing and am not seeing the problem -- scrapes come out fine for me.

I suspect that the problem is not with Transmission but with that particular tracker that you're using.

comment:5 in reply to: ↑ 4 Changed 10 years ago by gunzip

  • Resolution set to invalid
  • Status changed from new to closed

Replying to jordan:

I've tried several trackers that have announce URLs of the form you're describing and am not seeing the problem -- scrapes come out fine for me.

I suspect that the problem is not with Transmission but with that particular tracker that you're using.

i tested that theory and you are right. on that same tracker rtorrent reports "S/L: 0/0" eventhough it connects and downloads fine, i.e., same behavior as transmission.

since this appears to be such a narrow case and performance is not affected i'm going to close this ticket. in any case, transmission-show does work so i can always scrape with that if needed.

comment:6 Changed 10 years ago by gunzip

  • Resolution invalid deleted
  • Status changed from closed to reopened

this problem seems to be fixed for me with r12605 .. valid scrape numbers are now being returned

i'll go ahead and mark this ticket as fixed.

comment:7 Changed 10 years ago by gunzip

  • Resolution set to fixed
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.