Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4168 closed Bug (invalid)

transmission-gtk 2.30beta: High cpu load on broken blocklist

Reported by: ungifted Owned by: jordan
Priority: Normal Milestone: 2.30
Component: libtransmission Version:
Severity: Normal Keywords:
Cc:

Description (last modified by jordan)

With broken blacklist I have 100% cpu load in transmission-gtk.

Backtrace for thread:

#0  0x00007f461bbc7746 in ?? () from //usr/lib64/opengl/nvidia/lib/libGL.so.1
#1  0x00007f461aa2a84d in ?? () from //usr/lib64/opengl/nvidia/lib/libnvidia-tls.so.270.30
#2  0x000000000048971e in blocklistClose (b=0x237ec20) at blocklist.c:71
#3  0x000000000048a0ef in _tr_blocklistSetContent (b=0x237ec20, filename=0x2432460 "/skipped/.config/transmission/blocklist.txt.tmp") at blocklist.c:343
#4  0x000000000046b2b0 in tr_blocklistSetContent (session=0x1d9e680, contentFilename=0x2432460 "/skipped/.config/transmission/blocklist.txt.tmp") at session.c:2291
#5  0x00000000004632a1 in gotNewBlocklist (session=0x1d9e680, did_connect=true, did_timeout=false, response_code=200, response=0x237f590, response_byte_count=2945, user_data=0x246d790)
    at rpcimpl.c:1190
#6  0x000000000047f0f4 in task_finish_func (vtask=0x25b7fa0) at web.c:212
#7  0x0000000000479f72 in readFromPipe (fd=7, eventType=2, veh=0x1d9eca0) at trevent.c:192
#8  0x00007f462238c75c in event_base_loop () from /usr/lib64/libevent-2.0.so.5
#9  0x000000000047a132 in libeventThreadFunc (veh=0x1d9eca0) at trevent.c:248
#10 0x000000000045df7d in ThreadFunc (_t=0x1d9dc80) at platform.c:118
#11 0x00007f461bbc5373 in ?? () from //usr/lib64/opengl/nvidia/lib/libGL.so.1
#12 0x00007f4621ae2e9c in start_thread (arg=0x7f461715b700) at pthread_create.c:301
#13 0x00007f462084fe0d in clone () at ../sysdeps/unix/sysv/linux/x86_64/clone.S:115

Change History (5)

comment:1 Changed 11 years ago by jordan

  • Description modified (diff)

comment:2 Changed 11 years ago by ungifted

  • Summary changed from transmission-gtk 2.30beta: High cpu load on broken blacklist to transmission-gtk 2.30beta: High cpu load on broken blocklist

comment:3 Changed 11 years ago by jordan

  • Component changed from GTK+ Client to libtransmission

comment:4 Changed 11 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

Strangely enough this appears to be an issue with nvidia's opengl libraries. Transmission doesn't use opengl, but apparently the nvidia drivers have a custom version of munmap.

Downstream ticket with more information: https://bugs.launchpad.net/transmission/+bug/734615

Okay, forgot to run ldconfig -X after update-alternatives so the nvidia's libGL was still being used. After properly selecting the Mesa libGL and ldconfig, I could not reproduce this.

comment:5 Changed 11 years ago by ungifted

Thanks Problem in nVidia libGL and confirmed here: http://www.nvnews.net/vbulletin/showthread.php?p=2408692

Note: See TracTickets for help on using tickets.