Opened 11 years ago

Closed 10 years ago

#4177 closed Bug (fixed)

"Torrent option" window of Transmission GTK leaves a process in memory upon adding a torrent

Reported by: kovalev Owned by: jordan
Priority: Normal Milestone: 2.40
Component: GTK+ Client Version: 2.30
Severity: Normal Keywords:
Cc:

Description

The issue can be easily seen while adding a torrent file to GTK client via Gnome nautilus, with Transmission set as a default application. "Torrent option" window is invoked immediately in this case (skipping standard open file dialogue), creating another process with the same name "transmission-gtk" as the parent process but different PID. This process won't go upon completion of adding the new torrent, but it can be killed later without apparent damage to the parent instance running.

The issue is not so obvious while using "File"-"Open" menu (Gnome standard open file dialogue might take care of it). Though it might be one of the causes of memory leak upon adding a new torrent.

Using Transmission GTK 2.22+ (12305) build on Ubuntu 10.10 amd64.

Attachments (1)

transmission.child.proc.png (13.0 KB) - added by kovalev 10 years ago.

Download all attachments as: .zip

Change History (6)

comment:1 follow-up: Changed 10 years ago by jordan

I'm not able to reproduce this issue. Could you be more specific on when exactly this child process is created?

When you say "is not so obvious while using File > Open", do you mean that it doesn't exist when opening the "Torrent option" dialog through "File > Open"?

Changed 10 years ago by kovalev

comment:2 in reply to: ↑ 1 Changed 10 years ago by kovalev

Replying to jordan:

To reproduce:

  • make sure Transmission is set as a default application for .torrent files;
  • with Transmission GTK running try to launch any .torrent file, for example in Gnome nautilus. "Torrent option" window of the client will be invoked skipping standard Gnome open file dialogue (since we have finished file selection process already). At this moment I always observed the appearance of the second "transmission-gtk" process with PID different from the parent's process (see attachment). The process takes ca. 1.6-2Mb of memory depending on the torrent size and won't go after adding a torrent is complete. Each time when I add a torrent this way, yet another child process is being created - just leaving the previous instance in memory. Later however all those child processes can be killed "manually" with no apparent damage to the parent.

Observed first with old builds of Transmission GTK (12305 and below) running on Ubuntu 10.10 amd64 and now confirmed on the latest release of Natty with Unity desktop.

I'm not able to reproduce this issue. Could you be more specific on when exactly this child process is created?

I never noticed such a behaviour while adding a torrent via standard "File-Open" path using Gnome open file dialogue. However, each time when "Torrent options" is invoked the memory usage of the main process increases by the similar 1.6-2Mb increment. And upon restarting the client its memory footprint returns to new "normal" value.

When you say "is not so obvious while using File > Open", do you mean that it doesn't exist when opening the "Torrent option" dialog through "File > Open"?

comment:3 Changed 10 years ago by jordan

  • Version changed from 2.22+ to 2.30

comment:4 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.40
  • Status changed from new to assigned

Using GApplication to ensure there's only a single transmission-gtk process should take care of this.

GApplication support was added in r12656

comment:5 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed
Note: See TracTickets for help on using tickets.