Opened 10 years ago

Closed 10 years ago

Last modified 8 years ago

#4213 closed Bug (invalid)

Setting torrent priority to high monopolizes bandwidth

Reported by: rb07 Owned by: jordan
Priority: Normal Milestone: None Set
Component: libtransmission Version: 2.22
Severity: Normal Keywords:
Cc: federicoleva@…

Description

I just used the priority setting twice on torrents I was seeding, and noticed three strange details:

  • The torrent with high priority (all others with normal priority) takes all the upload bandwidth, after a while (i.e. not immediately). This could be useful for initial seeding;
  • The other torrents that where seeding don't disappear from the active list, and keep their connections to peers. This I don't like, the other peers get a useless connection;
  • Downloading is not affected (other torrents that are downloading keep downloading, but also don't upload).

Haven't tested with 2.30 betas, but I don't see a ticket that affects priorities.

Change History (3)

comment:1 Changed 10 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

If possible, shouldn't the high-priority transfer get bandwidth over the lower-priority transfers? The other transfers should keep peer connections if there is the potential for transfer, but priority for data transfer should be given to the transfers with the highest priority. I don't believe this is a bug - this is by design.

comment:2 Changed 10 years ago by rb07

I don't agree.

Another point that shows that it is a bug: the other torrents will not upload as long as one torrent has high priority.

Is that really the design? Just one torrent works, or even all that have high priority? then what's the use of having 3 levels of priority?

I don't know what design was followed, but the usual priority system is a weighted system, the higher the priority the more weight is used in a calculation (of whatever).

comment:3 Changed 8 years ago by Nemo_bis

  • Cc federicoleva@… added

This bug is definitely invalid. I wish it was true! It's not for me (which would be an actual bug), do you still see it in 2.82 (14160)?

Note: See TracTickets for help on using tickets.