Opened 10 years ago

Closed 10 years ago

#4233 closed Bug (worksforme)

transmission doesn't delete torrent data

Reported by: performance Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.12
Severity: Normal Keywords:
Cc:

Description

steps to reproduce

  1. transmissionbt runs out of space
  2. make space and then try to delete a torrent with its data using RPC
  3. torrent will be deleted but not the data

Change History (11)

comment:1 Changed 10 years ago by livings124

Do you mean .torrent file? Transmission manages data files, not the .torrent files, so I would expect the opposite. What happens in 2.22 or 2.30b4?

comment:2 Changed 10 years ago by jordan

When you say "delete a torrent with its data using RPC," which RPC client are you using?

comment:3 Changed 10 years ago by performance

UPDATE: Its happening again, except it has nothing to do with empty space. It just happens now. I have no idea why.

By delete a torrent I mean both in transmission's list and the data on the disk. I am using transmissionrpc(python bindings) and it used to work fine.

comment:4 Changed 10 years ago by performance

I think it might have to do with changing the download speed limit. Thats the only thing I can think of thats different between when it was working and now.

comment:5 Changed 10 years ago by jordan

transmission's python RPC bindings are maintained by a third party, not by the transmissionbt.com team. You might want to contact the author of the python RPC bindings and submit a bug report there.

Does deleting the data work correctly for you in transmission-gtk?

comment:6 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen if there's more information. Right now this looks like a third-party issue.

comment:7 Changed 10 years ago by performance

  • Resolution worksforme deleted
  • Status changed from closed to reopened

Has there been any undocumented changes? I've checked the RPC call to remove and delete local data and the response is "success". The torrent is deleted but not its data.

I compared deleting using the python bindings vs transmission-remote cli and only difference I can see in the arguments is

"delete-local-data":true vs delete-local-data":1

the top one is transmission-remote and it works fine, the bottom one is the transmissionrpc module.

comment:8 Changed 10 years ago by jordan

No, there have been no undocumented changes that I know of. Everything that we change to the RPC interface gets listed in the changes section at the bottom of the spec.

Even though "true" is more correct, "1" should still work. You might try poking at the python bindings to send "true" for testing purposes though.

"success" means that the request is acknowledged... see #2870

Since you're able to reproduce this issue at will, you might want to try running Transmission inside a debugger, set a breakpoint for tr_torrentRemove(), and step through it to see what's going on.

comment:9 Changed 10 years ago by jordan

@performance: any news?

comment:10 Changed 10 years ago by performance

not really. The problem disappeared after a reboot. I think I might have had two or more transmissionbt's on the same port.

comment:11 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.