Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4245 closed Bug (fixed)

The spacebar does multiple things in the Files - Torrent Inspector

Reported by: asmeurer Owned by: livings124
Priority: Normal Milestone: 2.32
Component: Mac Client Version: 2.30
Severity: Normal Keywords:
Cc:

Description

If you select a file in the Files - Torrent Inspector, it both checks or unchecked the checkbox of the selected file, and it opens a QuickLook? thing for the torrent. If you press the spacebar again, it closes the QuickLook? thing and changes the front window to the main Transmission window.

I don't think that the QuickLook? thing should open in the inspector. This makes it impossible to change the checkbox selection of many files quickly by arrowing to them and pressing the spacebar.

Bug observed in latest stable version of Transmission (2.30 (12439)) on Mac OS X 10.6.7. Let me know if you need more information, or help debugging.

Change History (7)

comment:1 Changed 10 years ago by livings124

The spacebar doesn't toggle checkboxes for me. Do you have special settings configured on your system?

comment:2 follow-up: Changed 10 years ago by Waldorf

Same, though I thought this was by design.

System Preferences > Keyboard > Keyboard Shortcuts > All controls toggles this behavior.

comment:3 in reply to: ↑ 2 Changed 10 years ago by x190

Replying to Waldorf:

Same, though I thought this was by design.

System Preferences > Keyboard > Keyboard Shortcuts > All controls toggles this behavior.

Confirmed. Spacebar should not toggle file selection when "All controls" radio button is selected in System Preferences > Keyboard > Keyboard Shortcuts (bottom left of pane).

comment:4 Changed 10 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:5 Changed 10 years ago by asmeurer

Hmm. I've always just assumed that the spacebar toggled checkboxes. I didn't realize that you had to have that option to do it. I thought that option was just to change what the tab key selected.

Anyway, it would be nicer if you made it not activate QuickLook? (which is kind of useless anyway) than if you disabled the checkbox toggling.

comment:6 Changed 10 years ago by livings124

  • Milestone changed from None Set to 2.32
  • Resolution set to fixed
  • Status changed from new to closed

comment:7 Changed 10 years ago by x190

"Spacebar should not toggle file selection when "All controls" radio button is selected in System Preferences > Keyboard > Keyboard Shortcuts (bottom left of pane)."

I would like to correct this statement from comment:3. Checkbox toggling appears in fact to be the proper behaviour in "All controls" mode. Sorry!

If Quicklook has been disabled in the Inspector, this might be a mistake as QL in Transmission is useless without Inspector support.

Note: See TracTickets for help on using tickets.