Opened 10 years ago

Closed 10 years ago

#4254 closed Bug (fixed)

Can`t see description about Flags

Reported by: allfoxwy Owned by: jordan
Priority: Normal Milestone: 2.32
Component: GTK+ Client Version: 2.31
Severity: Minor Keywords:
Cc:

Description

OS: Ubuntu 10.04.2 LTS kernel: 2.6.32-30-generic transmission version: 2.31

In the torrent Properties dialog`s Peers tab, when I move mouse on the Flags column, it should show me a balloon to describe the meaning of the Flags as it did in 2.22, but this is not working in 2.31, it only show me a blank balloon.

http://www.keyfc.net/bbs/space/upload/2011/05/18/567840380.png

Attachments (1)

markup.diff (861 bytes) - added by jordan 10 years ago.
possible fix

Download all attachments as: .zip

Change History (8)

comment:1 Changed 10 years ago by howl

Localized in spanish works, try to use the default LANG=C to see if it's a problem with the locale you are using.

comment:2 Changed 10 years ago by allfoxwy

Well, I just find that this problem is triggered by torrent`s title. A torrent title with a '&' in it will cause this problem.

I attached a torrent with '&' in its title for you to reproduce this problem.

comment:3 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.32
  • Severity changed from Normal to Minor
  • Status changed from new to assigned

Your torrent didn't come through, but that's okay. Your info in comment:2 is enough to go on. Thanks for the detective work!

Changed 10 years ago by jordan

possible fix

comment:4 follow-up: Changed 10 years ago by jordan

allfoxwy, could you test markup.diff and see if it solves the problem?

comment:5 in reply to: ↑ 4 Changed 10 years ago by allfoxwy

Replying to jordan:

allfoxwy, could you test markup.diff and see if it solves the problem?

I installed Transmission from PPA, and don`t know how to build it from source, so could someone else test it out?

comment:6 Changed 10 years ago by jordan

Sure, I'll try to test it out over the weekend

comment:7 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

looks like that did the trick. fixed in r12465

Note: See TracTickets for help on using tickets.