Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4259 closed Bug (worksforme)

Massive memory leak when adding torrent in transmission-daemon 2.31

Reported by: wooptoo Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.31
Severity: Normal Keywords:
Cc:

Description

After upgrading to version 2.31 I noticed that when I add a torrent transmission-daemon suddenly uses a lot of memory. It goes from about 9MB to 200MB in a second. Memory usage does not decrease afterwards.

This didn't happen in version 2.22.

I'm running Linux 64bit 2.6.38.

Attachments (1)

dump.zip (19.0 KB) - added by wooptoo 10 years ago.
massif and memcheck dumps

Download all attachments as: .zip

Change History (12)

comment:1 Changed 10 years ago by jordan

When I start transmission-daemon and it's running idle with no torrents, it uses 600 KiB. After adding a torrent it goes to 11.1 MiB, which is reasonable since the cache size in my settings.json is 8 MiB.

I'm definitely not seeing the 191 MiB jump that you're describing.

Tested with torrent http://www.linuxmint.com/torrent/linuxmint-10-gnome-cd-i386.iso.torrent on a Linux 2.6.34 box.

comment:2 Changed 10 years ago by wooptoo

I already have 20 torrents seeding. When I add a new one it starts to leak. I also get this error on the added torrent:

Error: Unable to save resume file: Too many open files

comment:3 Changed 10 years ago by jordan

So you're saying that the leak only starts happening on the 21st torrent? Do I need to load up 20 other torrents in order to reproduce this error, or am I misunderstanding your report?

comment:4 Changed 10 years ago by wooptoo

I'm saying that maybe you need a few active torrents to reproduce the issue.

comment:5 Changed 10 years ago by jordan

I'm still not able to reproduce this problem.

Any chance you could run your session inside of massif to get a trace of where the memory consumption is coming from?

Changed 10 years ago by wooptoo

massif and memcheck dumps

comment:6 Changed 10 years ago by jordan

Something's not right with that massif output... it's showing the maximum memory usage was 17.45 KB.

The memcheck dump reports no leaks either.

comment:7 Changed 10 years ago by wooptoo

I added another comment after the dumps, but it seems the moderation system ate it.

When trying to reproduce the bug in valgrind (adding a new torrent), Transmission crashed. It crashed in both instances (memcheck and massif).

Maybe it has something to do with open-file-limit? When this bug happens, Transmission complains about exceeding the open-file-limit (currently set to 32).

comment:8 Changed 10 years ago by jordan

32 is awfully small. Why are you using such a small value?

comment:9 Changed 10 years ago by wooptoo

I set the open-file-limit to 128. When adding a new torrent the memory still jumps from 9M to 135M. And Transmission still complains about too many opened files.

comment:10 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

I'm still not able to reproduce this issue.

Please reopen this ticket when more information is available.

comment:11 Changed 10 years ago by wooptoo

Cannot reproduce anymore in ver 2.33.

Note: See TracTickets for help on using tickets.