Opened 10 years ago

Closed 10 years ago

#4266 closed Enhancement (duplicate)

2.31 announces to tracker even though torrent is 'paused'

Reported by: hbt Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.31
Severity: Normal Keywords:
Cc:

Description

The logfile is spammed with 'Tracker error: You are using a banned client' every 5 minutes although the torrent is paused.

It looks like transmission ignores the 'pause' option and announces nonetheless.

Change History (8)

comment:1 Changed 10 years ago by livings124

Are you sure those aren't from scrapes?

comment:2 Changed 10 years ago by hbt

Nope, not sure, it was just a guess. You could be right, because I noticed that scrape-stuff is displayed, eg how many seeders/leechers.

What's the right approach here? Disable scrape for paused torrents?

comment:3 Changed 10 years ago by jordan

My guess is that it scrapes, not announces, which would make this a dupe of #3219.

You can confirm, if you want, by logging the http traffic by running Transmission from the command line after setting the TR_CURL_VERBOSE environment variable to nonzero...

comment:4 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

comment:5 Changed 10 years ago by hbt

  • Resolution duplicate deleted
  • Status changed from closed to reopened
  • Type changed from Bug to Enhancement

what about:

  1. make an option to disallow scrape on paused torrents

or

  1. introduce 'stop' to completely shut up torrents (and discard half downloaded chunks etc)

comment:6 Changed 10 years ago by livings124

  • Resolution set to wontfix
  • Status changed from reopened to closed

As you see from the other ticket, this has already been discussed and turned down.

comment:7 Changed 10 years ago by jordan

  • Resolution wontfix deleted
  • Status changed from closed to reopened

comment:8 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.