Opened 10 years ago

Closed 10 years ago

#4280 closed Bug (fixed)

More discreetly color torrents that have an error message

Reported by: mag Owned by: jordan
Priority: Normal Milestone: 2.32
Component: Qt Client Version: 2.31
Severity: Normal Keywords:
Cc:

Description

When there is an error message regarding a torrent, all the text for this torrent in the list is colored red. This pulls in a lot of attention for that particular torrent.

In many cases the error state is transient, and does not justify the amount of attention the red coloring grabs.

I suggest a more modest coloring of torrents in an error state.

I have attached a patch for more discreetly, but still obviously, marking the torrent as having an error.

Attachments (1)

more_discreet_error_coloring.diff (1.1 KB) - added by mag 10 years ago.

Download all attachments as: .zip

Change History (4)

Changed 10 years ago by mag

comment:1 Changed 10 years ago by jordan

This isn't a bad idea, but I wonder if it addresses the symptom rather than the disease.

One complaint I've seen growing recently is that Transmission is too quick to show error messages that don't matter. For example, if there is a public torrent with 5 trackers, but one tracker returns an error message, that torrent goes red even though there are 4 more trackers working perfectly fine.

And, given how many trackers people like to load into their .torrent files for redundancy, it's often 10 or 15 trackers rather than 5.

Is your motive for coloring errors more discreetly related to that issue?

comment:2 Changed 10 years ago by mag

My motivation is (of course ;) that I feel like all my torrents are all red, all the time, because of what you say. If I didn't have to look at all that red text all the time, I would not have created this ticket. So there is some kind of trade-off involved; The redness/visual noise caused by an error should be roughly proportional to the severity of the error.

I am not convinced that there exists an error condition severe enough to color all the text red. I think this is too noisy, so my conclusion is that I would still like this patch to be accepted even if the error messages from the daemon were to become sensible.


Another consideration entirely is the comparison with the other interfaces, specifically the web interface.

The attached patch makes the error messages in the qt client look more like how they look in the web interface. This is a good thing, because it makes Transmission look more like one "thing" -- more recognizable -- even if it consists of several different programs.

Also, it looks better :)

comment:3 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.32
  • Resolution set to fixed
  • Status changed from new to closed

The issue I described in comment:1 is addressed in r12516 ...

I don't really agree with the rest of this ticket. IMO the core problem is that we're highlighting too many useless errors (ie, tracker errors that don't matter in a multitracker setting). The color change patch solves this issue, but its approach also de-emphasizes legitimate error messages that users need to see.

Closing this ticket as "fixed." Neither "fixed" nor "invalid" are a perfect fit, but since a commit was made about tracker errors, "fixed" is the closer fit...

Note: See TracTickets for help on using tickets.