Opened 10 years ago

Closed 10 years ago

#4310 closed Bug (duplicate)

transmission seems to ignore blocklists

Reported by: mr-4 Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.31
Severity: Normal Keywords: blocklist
Cc:

Description

I have 6 files which contain my blocklists - level1-level5 and levelxx (containing customised - i.e. user-added - locations I consider not worthy of transmission's attention) - this is compiled by transmission to level1.bin-level5.bin and levelxx.bin respectively, but they all seem to be ignored by transmission as I have the same entries in my firewall's blocklist (i.e. packets originating from/destined to to be dropped without further consideration) and the count for these is quite significant - all coming from transmission.

I have "blocklist-enabled": true in my settings.json, so the blocklist is activated.

That seems to be the case because when I have (log) message-level 2, transmission reports "xxx entries found in levelXXX.bin", so I think it "sees" them, though for some unknown to me reason, it just ignores them as connection attempts are made to these locations.

Change History (3)

comment:1 follow-up: Changed 10 years ago by x190

Are you using DHT? If so this could be the problem. I have raised this issue before as I feel we should not be networking with peers (nodes) with whom we would not data share. The other possible problem might be µTP. Could you please test with first DHT then µTP and then both disabled and report the results?

Thank you for raising the issue!

comment:2 in reply to: ↑ 1 Changed 10 years ago by mr-4

Replying to x190:

Are you using DHT? If so this could be the problem. I have raised this issue before as I feel we should not be networking with peers (nodes) with whom we would not data share. The other possible problem might be µTP. Could you please test with first DHT then µTP and then both disabled and report the results?

Yeah, you guessed it right - I am using both DHT and µTP (the main reason to upgrade to 2.30 - I was on 2.12 before). To me, the blacklist should be respected regardless of what I am using (DHT, µTP or both) - blacklist is a blacklist at the end of the day and peers listed in it should not be contacted or used in any way!

I will try and do as you suggested and report back.

Thank you for raising the issue!

Pleasure!

comment:3 Changed 10 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #4016.

Note: See TracTickets for help on using tickets.