Opened 10 years ago

Closed 10 years ago

#4320 closed Enhancement (fixed)

Port GTK client to GTK 3.

Reported by: Mad Fish Owned by: jordan
Priority: Normal Milestone: 2.40
Component: GTK+ Client Version: 2.31
Severity: Normal Keywords:
Cc: pva@…

Description

To integrate nicely with GNOME 3 and upcoming Ubuntu 11.10 (which will be using GTK 3 as well).

Change History (5)

comment:1 Changed 10 years ago by pva0xd

  • Cc pva@… added

comment:2 Changed 10 years ago by jordan

In addition to the obvious get-it-to-compile changes required for GTK+ 3.0, I'd also like to drop our custom dbus code and lockfile code, replacing it with GTK's GtkApplication? API instead.

Ticket #4307, which concerns our custom dbus code, has been closed as a duplicate of this ticket.

comment:3 Changed 10 years ago by jordan

  • Component changed from Transmission to GTK+ Client
  • Milestone changed from None Set to Sometime
  • Owner set to jordan
  • Status changed from new to assigned

#4001 also talks about using GtkApplication?, so I'm folding that ticket into this one as well.

comment:4 Changed 10 years ago by jordan

jordan * r12591 gtk/ (torrent-cell-renderer.c tr-window.c): (trunk gtk) #4320 "Port GTK client to GTK 3." -- transmission-gtk now compiles cleanly & runs on GTK 3.

comment:5 Changed 10 years ago by jordan

  • Milestone changed from Sometime to 2.40
  • Resolution set to fixed
  • Status changed from assigned to closed

2.40 now uses GApplication instead of homegrown lockfiles and dbus calls.

Note: See TracTickets for help on using tickets.