Opened 10 years ago

Closed 10 years ago

Last modified 9 years ago

#4324 closed Bug (invalid)

Don't build tests during normal build

Reported by: pva0xd Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.31
Severity: Normal Keywords:
Cc:

Description

Transmission builds tests binaries during normal build. This is not necessary and patch in attachment makes build system build test binaries only during make check.

Attachments (1)

transmission-2.31-no-tests.patch (504 bytes) - added by pva0xd 10 years ago.
transmission-2.31-no-tests.patch

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by pva0xd

transmission-2.31-no-tests.patch

comment:1 Changed 10 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

This is intentional.

The tendency, when using check_PROGRAMS, is to not build the tests until "make distcheck" is run. By making it part of the regular build process, any breakage caused by changes in libtransmission is automatically found sooner, before checkin.

I agree that this is a subjective judgement call, but it's an intentional one.

comment:2 Changed 9 years ago by samuli

Please reconsider this bug.

We are stuck with carrying this patch in Gentoo Linux and autoreconfiguring the package for each and every user, everytime, when installing transmission to avoid building unwanted tests.

As in, please think of the end users.

Note: See TracTickets for help on using tickets.