Opened 10 years ago

Closed 6 years ago

#4325 closed Bug (fixed)

GTK+ client's docs are out-of-date

Reported by: costela Owned by: John Clay
Priority: Low Milestone: None Set
Component: Website Version: 2.31
Severity: Minor Keywords: docs screenshot graph completeness
Cc:

Description

Hi,

The completeness graph that can be seen here doesn't actually exist anymore. Apparently it hasn't existed for a while.

Could someone with write access to the help directory please upload a new screenshot for all newer versions without this feature?

Unfortunately I couldn't find out exactly when this feature was removed, so I just marked this as Version:2.00+, but if someone can find the commit that did it, please change the Version accordingly.

Change History (5)

comment:1 Changed 10 years ago by jordan

  • Summary changed from remove completeness graph screenshot from docs to GTK+ client's docs are out-of-date
  • Version changed from 2.00+ to 2.31

The issue is that *most* of that documentation is out-of-date, as can be seen from the intro page's call for volunteers. Picking out that screenshot seems to miss the point -- if I update that screenshot, most of the rest of that page is still obsolete.

The help pages need a ground-up rewrite along the same lines as http://www.transmissionbt.com/help/gtk/2.3x/html/preferences.html but in order for that to happen, someone needs to volunteer to do it.

Tweaking the ticket's summary & stats to reflect this...

comment:2 Changed 10 years ago by octoquad

Hi,

I would like to volunteer to get this documentation updated. How can I help out and what are the requirements? Is it not possible to merge the existing documentation with trac or would you prefer it if someone re-wrote this with HTML5 & CSS3?

comment:3 Changed 10 years ago by jordan

Hi octoquad,

Thanks for volunteering to update the documentation!

At this point, nearly all of the GTK+ documentation is badly out-of-date except for the preferences dialog's help page. If you think it would be easier to start with a clean slate and use HTML5/CSS3, that would be fine.

comment:4 Changed 10 years ago by octoquad

jordan,

Thanks for the getting back to me! I will get this going soon, I just need setup my dev environment.

comment:5 Changed 6 years ago by John Clay

  • Resolution set to fixed
  • Status changed from new to closed

The documentation has been updated recently. If there are improvements to be made, please re-open the ticket.

Note: See TracTickets for help on using tickets.