Opened 10 years ago

Closed 10 years ago

#4333 closed Bug (worksforme)

transmission-daemon 2.31 crashes randomly at Ubuntu 11.04

Reported by: ilu Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.31
Severity: Normal Keywords: daemon, random crash, linux, ubuntu
Cc:

Description

I'm running transmission-daemon 2.31 from transmissionbt-ppa on 64bit Ubuntu 11.04 using Linux 2.6.39-0-generic #5~20110427-Ubuntu SMP Wed Apr 27 15:27:41 UTC 2011 x86_64 x86_64 x86_64 GNU/Linux.

It randomly crashes and lefts message to dmesg

[1388792.105440] transmission-da[28606]: segfault at 0 ip 0000000000407000 sp 00007f038ba9e9c0 error 4 in transmission-daemon[400000+6f000]

[730618.453643] transmission-da[20088]: segfault at 0 ip 0000000000407000 sp 00007f21e51769c0 error 4 in transmission-daemon[400000+6f000]

(Note these are two different crashes wich I found from dmesg log)

I tried to backtrace this with guide from https://wiki.ubuntu.com/Backtrace and it resulted to crash but with transmission-daemon still running if I check from process list. GDB log can be found http://pastebin.com/9JJdqRCG This time it didn't left any message to dmesg.

Change History (11)

comment:1 Changed 10 years ago by ilu

It seems it did'nt exactly crash when running that backtrace, anyway full log for that can be found http://pastebin.com/C3xMrUeV

Still running GDB and waiting when it segfaults again.

comment:2 Changed 10 years ago by jordan

The SIGPIPE in gdb is a red herring; see http://ahlamnote.blogspot.com/2006/12/gdb-ignore-sigpipe.html for more info.

Would it be possible to get an updated gdb backtrace?

comment:3 Changed 10 years ago by ilu

I started gdb again with 'handle SIG33 pass nostop noprint SIGPIPE'

comment:4 Changed 10 years ago by jordan

I'm not sure whether or not that will work. If it doesn't, use a separate handle command for SIGPIPE

comment:5 Changed 10 years ago by ilu

Looks like it doesn't work (for some reason it still pauses that process.)

I haven't used gdb (or any backtrage program) before, any good tips what options I should give it and how?

comment:6 Changed 10 years ago by jordan

I'd try

(gdb) handle SIGPIPE nopass noprint nopstop
(gdb) run

comment:7 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Closing this ticket as a duplicate of #2071.

I agree with the goals of this ticket, but I think the arguments I made in https://trac.transmissionbt.com/ticket/2071#comment:8 are still valid...

comment:8 Changed 10 years ago by jordan

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Gahh, that comment was meant for #4323, not #4333...

comment:9 Changed 10 years ago by jordan

ilu, is there any news?

comment:10 Changed 10 years ago by ilu

Not really, it crashed once but there was power outake earlier so gdb wasn't running. At the moment running gdb again and waiting something to happen.

comment:11 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from reopened to closed

Please reopen this ticket when more information is available. Thank you!

Note: See TracTickets for help on using tickets.