Opened 10 years ago

Closed 10 years ago

#4349 closed Bug (worksforme)

turtle speed limit

Reported by: t3k4t4k Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.32
Severity: Normal Keywords: bandwidth regulate turtle speed limit
Cc:

Description

Mac OS X 10.5.8
Transmission 2.32 (12526)

The turtle speed limit to override the global speed limit is not working correctly. It appears to be regulating the upload and download bandwidth briefly then returning back to unlimited, then regulating briefly, and repeating. See the attached image of my bandwidth with attention to the sinusoidal regulation of the speed between unlimited and a set limit. The lower trace is download bandwidth, the upper trace is upload bandwidth.

Attachments (1)

bandwidth trace.jpg (12.9 KB) - added by t3k4t4k 10 years ago.
upload and download bandwidth trace

Download all attachments as: .zip

Change History (3)

Changed 10 years ago by t3k4t4k

upload and download bandwidth trace

comment:1 Changed 10 years ago by jordan

All speed limiting in Transmission works by allocating small amounts of bandwidth to each peer a couple of times per second, which is the cause of the pulsing pattern that you're observing.

However, I don't see how this counts as a bug? The pulses are small and mostly harmless.

comment:2 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen this ticket when more information is available.

Note: See TracTickets for help on using tickets.