Opened 10 years ago

Closed 10 years ago

#4350 closed Bug (worksforme)

No data found!

Reported by: t3k4t4k Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.32
Severity: Normal Keywords: no data found
Cc:

Description

Mac OS X 10.5.8
Transmission 2.32 (12526)

I download torrents to an external drive connected via firewire800 as I have limited local storage.
-I click the torrent link
-It loads into transmission
-Downloading starts and gets up to a few KB or MB
-Then I get the following error:
No data found! Ensure your drives are connected or use "Move Data File To…". To re-download, remove the torrent and re-add it.

I search my computer for the partial file and can't find it. I've searched during the time it shows that it is downloading, as well as after the failed error is displayed.

If I don't 'Remove Data File...' out of Transmission and download the torrent again, VERY RARELY, the file will appear on my external drive after several minutes/hours. As if it's being slowly copied from a mysterious temporary location to my external drive. But most often I 'Remove Data File...' and download the torrent again. Only once in a while it works and the file shows up on the external drive.

I have a work around: I download to a local folder on my computer. When the torrent data file shows up in my local folder I 'Move Data File To...' my external drive. This works for every torrent.

More than having a fix I want to know what location Transmission is downloading the file to during the initial download phase, before getting the error from Transmission failing to copy the file to the user specified location.

Change History (9)

comment:1 Changed 10 years ago by jordan

t3k4t4k,

Just to make sure I understand correctly -- are you saying that Transmission gives the "No data found!" error for new torrents that you're adding for the first time to Transmission, and trying to save to an external drive which is connected and mounted?

comment:2 Changed 10 years ago by ziggo

I have the exact same error message. However, I download to a folder on the local drive of my laptop, so the workaround proposed in the ticket will not work. My info:

Mac OS X 10.6.8 Transmission 2.33, but the same happened with 2.20 (I rolled back to a random previous version)

comment:3 Changed 10 years ago by polarist

Same error message and steps to reproduce. Downloading to local drive on laptop, in "~/Downloads/" folder. Using Transmission 2.33 on Mac OS X 10.6.8.

comment:4 Changed 10 years ago by A1oki

I've been having the same problem. It will download for a few minutes and download a few MB or less then i get the error message, No data found! delete and re-add.

It's happen both when using OSX 10.6.8 and after i updated to OSX 10.7 I'm using the new 27-inch iMac with both SSD and HDD, I have it setup so torrents are save to the HDD instead of the SSD drive.

comment:5 Changed 10 years ago by sfera

i had a similar problem today with transmission-daemon 2.33 on linux. adding a torrent would always display "No data found! Ensure your drives are..." and would crash after a few attempts to add/remove torrents (using the web gui).

my config is something like ~/Torrent for complete files and ~/Torrent/.incomplete for the incomplete torrents.

the problem seemed to be that the incomplete dir was just gone missing. no other script/program has anything to do with that directory, so i must assume it was transmission who deleted it. just readding the dir solved the problem.

in any case, the displayed error message was misleading.

comment:6 Changed 10 years ago by sfera

this seems directly related to #4377

comment:7 Changed 10 years ago by jordan

#4377 has been fixed. Does this ticket's issue still persist in the nightly builds?

comment:8 Changed 10 years ago by x190

IMO, this ticket can closed.

comment:9 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Please reopen if this is still an issue.

Note: See TracTickets for help on using tickets.