Opened 10 years ago

Closed 10 years ago

#4352 closed Bug (duplicate)

Transmission daemon does not create directory in destination.

Reported by: jberzins Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.31
Severity: Minor Keywords:
Cc:

Description

I am adding a new torrent with transmission rpc.

  1. If target destination directory exists the downloadable file is created.
  2. If target destination directory does not exist transmission daemon does not try to create it and reports an error.

Scenario a:

  1. Directory "/media/stuff/Shows/The Show/Season 1" exists
  2. Add new torrent with location: "/media/stuff/Shows/The Show/Season 1/TheShowS01E01.mkv"
  3. Result - File is being dowloaded to "/media/stuff/Shows/The Show/Season 1/TheShowS01E01.mkv"

Scenario b:

  1. Directory "/media/stuff/Shows/The Show/" exists
  2. Directory "/media/stuff/Shows/The Show/Season 1" does _NOT_ exist
  3. Add new torrent with location: "/media/stuff/Shows/The Show/Season 1/TheShowS01E01.mkv"
  4. Result - No such file or directory error.
  5. Expected result - Directory "/media/stuff/Shows/The Show/Season 1" is created, file "TheShowS01E01.mkv" is created.

Scenario a log:

[20:36:37.446] Couldn't read "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume": No such file or directory (utils.c:443)
[20:36:37.446] TheShow.s01e01.720p.mkv Couldn't read "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume" (resume.c:686)
[20:36:37.446] Saved "/var/lib/transmission-daemon/info//torrents/TheShow.s01e01.720p.mkv.caf6f26df7d42245.torrent" (bencode.c:1722)
[20:36:37.446] TheShow.s01e01.720p.mkv Pausing (torrent.c:1673)
[20:36:37.446] Saved "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume" (bencode.c:1722)
[20:36:37.446] TheShow.s01e01.720p.mkv Queued for verification (verify.c:260)
[20:36:37.446] TheShow.s01e01.720p.mkv Verifying torrent (verify.c:218)
[20:36:37.446] TheShow.s01e01.720p.mkv verifying torrent... (verify.c:61)
[20:36:37.446] TheShow.s01e01.720p.mkv Verification is done. It took 0 seconds to verify 1062680092 bytes (1062680092 bytes per second) (verify.c:155)
[20:36:38.447] TheShow.s01e01.720p.mkv Announcing to tracker (announcer.c:1454)
[20:36:42.447] TheShow.s01e01.720p.mkv Announcing to tracker (announcer.c:1454)
[20:36:42.447] TheShow.s01e01.720p.mkv Got 80 peers from tracker (torrent.c:515)

Scenario b log:

[20:27:44.397] Couldn't read "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume": No such file or directory (utils.c:443)
[20:27:44.397] TheShow.s01e01.720p.mkv Couldn't read "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume" (resume.c:686)
[20:27:44.397] Saved "/var/lib/transmission-daemon/info//torrents/TheShow.s01e01.720p.mkv.caf6f26df7d42245.torrent" (bencode.c:1722)
[20:27:44.397] TheShow.s01e01.720p.mkv Pausing (torrent.c:1673)
[20:27:44.397] Saved "/var/lib/transmission-daemon/info//resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume" (bencode.c:1722)
[20:27:44.397] TheShow.s01e01.720p.mkv Queued for verification (verify.c:260)
[20:27:44.397] TheShow.s01e01.720p.mkv Verifying torrent (verify.c:218)
[20:27:44.397] TheShow.s01e01.720p.mkv verifying torrent... (verify.c:61)
[20:27:44.397] TheShow.s01e01.720p.mkv Verification is done. It took 0 seconds to verify 1062680092 bytes (1062680092 bytes per second) (verify.c:155)
[20:27:45.397] TheShow.s01e01.720p.mkv Announcing to tracker (announcer.c:1454)
[20:27:48.397] TheShow.s01e01.720p.mkv Announcing to tracker (announcer.c:1454)
[20:27:49.397] TheShow.s01e01.720p.mkv Got 80 peers from tracker (torrent.c:515)
[20:28:09.399] Couldn't open "/media/stuff/Shows/The Show/Season 1": No such file or directory (fdlimit.c:365)
[20:28:09.399] TheShow.s01e01.720p.mkv tr_fdFileCheckout failed for "/media/stuff/Shows/The Show/Season 1/TheShow.s01e01.720p.mkv.part": No such file or directory (inout.c:100)
[20:28:09.399] TheShow.s01e01.720p.mkv No such file or directory (/media/stuff/Shows/The Show/Season 1/TheShow.s01e01.720p.mkv) (torrent.c:487)
[20:28:10.399] TheShow.s01e01.720p.mkv Pausing (torrent.c:1673)
[20:28:10.399] Couldn't open "/media/stuff/Shows/The Show/Season 1": No such file or directory (fdlimit.c:365)
[20:28:10.399] TheShow.s01e01.720p.mkv tr_fdFileCheckout failed for "/media/stuff/Shows/The Show/Season 1/TheShow.s01e01.720p.mkv.part": No such file or directory (inout.c:100)
[20:28:10.399] Saved "/var/lib/transmission-daemon/info/resume/TheShow.s01e01.720p.mkv.caf6f26df7d42245.resume" (bencode.c:1722)
[20:28:10.399] TheShow.s01e01.720p.mkv Announcing to tracker (announcer.c:1454)
[20:28:40.402] Couldn't open "/media/stuff/Shows/The Show/Season 1": No such file or directory (fdlimit.c:365)
[20:28:40.402] TheShow.s01e01.720p.mkv tr_fdFileCheckout failed for "/media/stuff/Shows/The Show/Season 1/TheShow.s01e01.720p.mkv.part": No such file or directory (inout.c:100)

Change History (1)

comment:1 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Thanks for describing the issue so well.

This appears to be a duplicate of #4305 -- closing this ticket as a duplicate.

Note: See TracTickets for help on using tickets.