Opened 10 years ago

Closed 10 years ago

#4358 closed Bug (invalid)

build on ubuntu: /bin/mkdir: cannot create directory `/usr/local/share/transmission': No such file or directory

Reported by: vangop Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.32
Severity: Normal Keywords:
Cc:

Description (last modified by jordan)

Building from source, stable 2.32. configure&&make&&checkinstall produces ...

installing zh_CN.gmo as /usr/local/share/locale/zh_CN/LC_MESSAGES/transmission-gtk.mo
installing zh_TW.gmo as /usr/local/share/locale/zh_TW/LC_MESSAGES/transmission-gtk.mo
make[1]: Leaving directory `/tmp/t/transmission-2.32/po'
Making install in web
make[1]: Entering directory `/tmp/t/transmission-2.32/web'
Making install in images
make[2]: Entering directory `/tmp/t/transmission-2.32/web/images'
Making install in buttons
make[3]: Entering directory `/tmp/t/transmission-2.32/web/images/buttons'
make[4]: Entering directory `/tmp/t/transmission-2.32/web/images/buttons'
make[4]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/transmission/web/images/buttons" || /bin/mkdir -p "/usr/local/share/transmission/web/images/buttons"
/bin/mkdir: cannot create directory `/usr/local/share/transmission': No such file or directory
make[4]: *** [install-dist_dataDATA] Error 1

Ubuntu 10.10 x64 This although works with make install. But checkinstall is a preferred way since it allows to manage the package.

Change History (5)

comment:1 Changed 10 years ago by jordan

  • Description modified (diff)

comment:2 Changed 10 years ago by jordan

I wonder if this is a 10.10 issue? I'm not able to reproduce this issue using Mint 11 + checkinstall 1.6.2 + the transmission 2.32 tarball. Here's the the log from that run, at the same point where your 10.10 run hits an error:

installing zh_CN.gmo as /usr/local/share/locale/zh_CN/LC_MESSAGES/transmission-gtk.mo
installing zh_TW.gmo as /usr/local/share/locale/zh_TW/LC_MESSAGES/transmission-gtk.mo
make[1]: Leaving directory `/home/charles/src/transmission-2.32/po'
Making install in web
make[1]: Entering directory `/home/charles/src/transmission-2.32/web'
Making install in images
make[2]: Entering directory `/home/charles/src/transmission-2.32/web/images'
Making install in buttons
make[3]: Entering directory `/home/charles/src/transmission-2.32/web/images/buttons'
make[4]: Entering directory `/home/charles/src/transmission-2.32/web/images/buttons'
make[4]: Nothing to be done for `install-exec-am'.
test -z "/usr/local/share/transmission/web/images/buttons" || /bin/mkdir -p "/usr/local/share/transmission/web/images/buttons"
 /usr/bin/install -c -m 644 cancel.png file_priority_buttons.png file_wanted_buttons.png info_activity.png info_files.png info_general.png info_peers.png info_trackers.png tab_backgrounds.png tab_backgrounds_highlight.png toolbar_buttons.png torrent_buttons.png '/usr/local/share/transmission/web/images/buttons'
make[4]: Leaving directory `/home/charles/src/transmission-2.32/web/images/buttons'
make[3]: Leaving directory `/home/charles/src/transmission-2.32/web/images/buttons'
Making install in graphics

comment:3 Changed 10 years ago by vangop

I have checkinstall 1.6.2-1. It was unable to create those dirs, but as you can see it could copy the files, so it is not permissions. Had to make install&&make unintstall&& checkinstall

comment:4 Changed 10 years ago by vangop

I think it is a checkinstall bug, I've just had a very similar issue with another package. Filed https://bugs.launchpad.net/ubuntu/+source/checkinstall/+bug/815506

comment:5 Changed 10 years ago by jordan

  • Resolution set to invalid
  • Status changed from new to closed

vangop: thanks for the follow-up

Note: See TracTickets for help on using tickets.