Opened 10 years ago

Closed 10 years ago

#4368 closed Bug (fixed)

Text from Inspector panel is copied not properly

Reported by: shadowlmd Owned by:
Priority: Normal Milestone: 2.40
Component: Web Client Version: 2.32
Severity: Normal Keywords:
Cc:

Description

In web interface if I copy some URL from torrent comment, it will not work, if I paste it in browser, though it will look ok. But in fact, there are some invisible/unicode characters in it. For example, this is URL that I copied from torrent comment: http:/​/​rutracker.org/​forum/​viewtopic.php?t=1123050, and it is seen in text editor like this: http:/?/?rutracker.org/?forum/?viewtopic.php?t=1123050

Change History (6)

comment:1 follow-up: Changed 10 years ago by livings124

Are you certain that the comment itself doesn't contain those bad characters?

comment:2 in reply to: ↑ 1 Changed 10 years ago by shadowlmd

Replying to livings124:

Are you certain that the comment itself doesn't contain those bad characters?

Yes, this happens with all torrents. Also, transmission-remote -i <torrent_id> shows correct information.

comment:3 Changed 10 years ago by livings124

  • Component changed from Transmission to Web Client

comment:4 Changed 10 years ago by livings124

Ah, confirmed.

comment:5 Changed 10 years ago by jordan

Looks like this is a side-effect of r8428 for #1188

comment:6 Changed 10 years ago by livings124

  • Milestone changed from None Set to 2.40
  • Resolution set to fixed
  • Status changed from new to closed

Fixed in r12573

Note: See TracTickets for help on using tickets.