Opened 11 years ago

Closed 11 years ago

#438 closed Bug (worksforme)

.90/.91 very high CPU usage

Reported by: craigyjack Owned by: somebody
Priority: Normal Milestone:
Component: Transmission Version: 0.91
Severity: Normal Keywords: CPU
Cc:

Description

I am running .91 transmission on Linux Ubuntu 7.10 gutsy gibbon. the problem was in .90 as well. Transmission uses mass amounts of CPU constantly, fluctuating between 10%-90% all the time. This is affecting my whole system, making other processes lag and slowing down the whole system. I do not know the root cause of the problem, but it definitely not normal for the program to use this much CPU.

Change History (9)

comment:1 Changed 11 years ago by craigyjack

  • Priority changed from Normal to Highest

comment:2 Changed 11 years ago by livings124

  • Milestone 0.92 deleted
  • Priority changed from Highest to Normal
  • Severity changed from Critical to Normal

comment:3 follow-up: Changed 11 years ago by charles

A shark profile would be nice.

comment:4 in reply to: ↑ 3 ; follow-up: Changed 11 years ago by craigyjack

Replying to charles:

A shark profile would be nice.

What is a shark profile? I will get one uploaded for you if you tell me how i can provide it to you.

comment:5 Changed 11 years ago by Danez

  • Severity changed from Normal to Major

I do have the same Problem on my gentoo system, my last used version 0.72 was running with 0% - 4% cpu-usage, but 0.92 is useing 10% to 50% cpu. I only use CLI.

comment:6 in reply to: ↑ 4 Changed 11 years ago by tiennou

Hmm, Shark is a MacOS X tool that polls a program stack to see which functions are most processor-intensive... I looked for a Linux/Unix? equivalent, but I didn't found one...

comment:7 Changed 11 years ago by charles

sysprof is the Linux equivalent

comment:8 Changed 11 years ago by Danez

  • Severity changed from Major to Normal

I retried 0.93 today and I don't have a high cpu-load.

CPU-Load is only high if transmission is verifying data, but i think that's normal on my PII ;)

comment:9 Changed 11 years ago by charles

  • Resolution set to worksforme
  • Status changed from new to closed

I'm closing this ticket for now, but anyone who is willing to provide Shark or sysprof logs showing a high load in Transmission is welcome to re-open it.

Note: See TracTickets for help on using tickets.