Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4385 closed Bug (worksforme)

Pausing Torrent in OS X 10.7 Knocks Network Offline

Reported by: gn0s1s Owned by: livings124
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.33
Severity: Major Keywords:
Cc:

Description

This has happened to me exactly once so far, and I'm more than willing to do any test that the devs want me to. I'm running 2.33 on OS X 10.7, and after downloading a new torrent, I right clicked and set it to "Resume right away", then clicked the torrent that was currently downloading and clicked the Pause button at the top of the window. That pause suddenly took the entire network access offline, meaning nothing worked at all after that, not Safari/Chrome?, not Transmission, nothing. The message I got after restarting TM, when it tried to connect to trackers, was that it could not establish a connection. I checked other computers on the network and they were just fine.

A reboot fixed the issue and restored networking capability, but I thought I'd better report that there seems to be a pretty major bug here (either in TM or in OS X 10.7) that can crash the entire OS's networking capabilities when you pause a torrent.

Change History (7)

comment:1 Changed 10 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:2 Changed 10 years ago by livings124

  • Component changed from Mac Client to Transmission

Seems like your network can't handle all the messages at once. How many transfers did you have running?

comment:3 Changed 10 years ago by gn0s1s

One transfer, 90 peer limit. The other transfers were all paused or waiting to start.

comment:4 Changed 10 years ago by livings124

Can you replicate this with a current nightly build?

comment:5 Changed 10 years ago by sharpshot_uk

I can't replicate this with 2.33. Can you tell me step by step how you reproduce this bug, so I can try it on my setup on 10.7?

comment:6 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

Closing, as this is not reproducible and their is not enough information.

comment:7 Changed 10 years ago by gn0s1s

Closing is probably the best option here. I have tried to replicate the problem both with the current release and the latest nightly, with no results. However, I have had many intermittent WiFi? drops since then, unrelated to Transmission (sometimes when Transmission is totally off). It seems there are quite a few WiFi? issues in OS X Lion, and the suggested workaround I've found is running a constant ping to the WiFi? router using something like:

ping `route get default | awk '(/gateway/){print $2}'`

It hasn't dropped yet since I started doing that. When I first reported this, I knew it was a long shot and that it might not actually be Transmission's fault, but since I was actively doing something in Transmission when it first happened, it seemed to be the best place to start (in case others saw similar behavior). In any case, hopefully this will help other OS X Lion Transmission users who have similar issues.

Note: See TracTickets for help on using tickets.