Opened 10 years ago

Closed 9 years ago

#4417 closed Bug (incomplete)

Data not found when saving to a (wireless) external disk in OSX

Reported by: plhu Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.33
Severity: Normal Keywords:
Cc:

Description

When I choose to save the torrent to a HDD attached a AirPort? Extreme, I open the disk in Finder and save it on the disk as normal. Some background information: The disk is always shown in Finder under "Shared -> <AirPort? Extreme name> -> <disk share name>". But not mounted in the filesystem until you click on it in Finder (or some program automount it for you). The Volume is mounted as normal under /Volumes/<disk share name>. The Volume will be mounted in the same path each time.

The problem is that Transmission will not remember the data path, and the next time Transmission start up it will save a copy on the local disk (Or pop up a message about not enough free space) instead of continuing to save it on the shared volume. Right clicking the torrent and choosing "Move Data File to.." and choose the download folder on the shared disk will temporarily fix the problem - until you quit and start Transmission again. Transmission will forget the data path every time you quit the program after saving to an Shared path (In my case, shared wireless via an AirPort? Extreme disk share).

Transmission will then start and save the torrent to local disk if you don't remember to change the location each time, or it will show you the "not enough space" box.

I'm not sure if this only occur on shared disks via AirPort? Extreme or if it's a global problem, but that's the setup I have and it's not working for me...

Possible solution: It would be a good idea to let Transmission remember the data path, even if it don't find the data this time. Because it may be on an external drive that isn't connect/mounted right now. Another thing that should be implemented is letting Transmission mount the volume automatically if it isn't already mounted. E.g. Time Machine will start looking for the disk in all Shares available and mount this automatically for you. If this is not implemented in addition to letting Transmission remembering where the data was, it would make Transmission not find the data and you have to manually mount the spesific volume and restart/resume the torrent(s).. So then you still end up to having to do some manual job to get it working..

Change History (6)

comment:1 Changed 10 years ago by plhu

I tried to test this further, and I have two files where one is seeding (2,6gb) and one is downloading (118mb). These two seems to work, and data file is found like it should be when restarting Transmission. But the torrent I discovered this bug is 52,9GB. So it seems like it may be a issue about big files on shared disks?

comment:2 Changed 10 years ago by plhu

Well, it seems like I found the bug. The data path is not remembered because the torrent is too big for the local disk, and because "Keep incomplete files in: .transmission (on local disc)" is checked, even if I moved the data file with the "Move data file to..." button. And because the big torrent is on pause I didn't get any notice, it just deleted the path.

comment:3 Changed 9 years ago by x190

plhu: Please modify this ticket so that it clearly and concisely states the issue and provide the exact steps to reproduce the problem. Or can the ticket now be closed?

comment:4 Changed 9 years ago by jordan

  • Component changed from Transmission to Mac Client
  • Owner set to livings124

comment:5 Changed 9 years ago by x190

Since OP hasn't updated this ticket, IMO, it can be closed unless more info is provided.

comment:6 Changed 9 years ago by livings124

  • Resolution set to needinfo
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.