Opened 10 years ago

Closed 10 years ago

#4418 closed Bug (worksforme)

Observed web client access server error under limited memory available

Reported by: leandroong Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.33
Severity: Normal Keywords:
Cc:

Description

browser: firefox v. 5.0 Problem: transmission web client having server access error while running ubuntu, utilizing 512MB only under overall 4GB total memory.

Transmission web client would opened but configuration in the preferences all blanks and no current torrents displayed.

Could I suggest to make this error silently, like display bottom/upper status messages with blinking letters and dissappear upon having good reconnection.

Change History (6)

comment:1 Changed 10 years ago by jordan

Thank you, but I'm not understanding your request. Could you give it another try and rephrase it?

comment:2 Changed 10 years ago by jordan

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

comment:3 Changed 10 years ago by leandroong

I was having Transmission-daemon frequent crashes when I said that and the effect of that to my firefox browser is having empty configuration in the preferences menu, like empty "download to: " textbox. I figure out the reason for this. It has something to do with cron job time set to run every 5mins. In the event of crashes or loss of internet access, transmission-daemon would crash. It would totally disappeared from taskbar listing when you run "top" command under putty. Solution: I just lower cron job for both "bt_check_time" and "bt_queue_time" to run every 2 mins. "Bt_check_time" is cron job for keep-alive, checking if tranmission is running and re-run the service if it is dead. "Bt_queue-time" is also cron job, for torrent queueing policy, ensuring that running torrents numbers is <= to specified by the user. With your 2.40b1 version, the scenario has changed, torrent queueing is already built-in, there is no need to run bt_queue_time cron job. Does your new version have keep-alive cron-job? I wish that you would add it also in your model. In summary, this ticket is about me experienced transmission crashed.

comment:4 Changed 10 years ago by jordan

If I remember correctly, you're running Ubuntu. Could you please use Ubuntu's crash report tool so that I can see how your copy of transmission-daemon is crashing?

Also, does the crash persist in 2.40 beta 1?

Please follow these instructions to have apport report a new bug about your crash that can be dealt with by the automatic retracer.

To generate a crash report:

If you are running the Ubuntu Stable Release you might need to enable apport in /etc/default/apport and restart.

Now open your file manager, navigate to your /var/crash directory and open the crash report you wish to submit.

If this fails you will have to open a terminal and file your report with 'ubuntu-bug /var/crash/_my_crash_report.crash' where _my_crash_report.crash is the crash you would like to report. If you get an error that you aren't allowed to access this report you will have to file it with 'sudo ubuntu-bug /var/crash/_my_crash_report.crash'.

comment:5 Changed 10 years ago by leandroong

Ubuntu has nothing to do with transmission-daemon crashed. Transmission server is running in the router. I did encountered the crash while ubuntu is running under virtualbox mode, doing some FW updates and compilation. The problem is more likely due to bandwith exhaustion. Limiting maximum download speed default to 60%, makes it ideal for me to surf internet and download torrents in harmony. I dont see this as bug in the program anymore. Ignore it for the meantime and consider it resolved.

comment:6 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

Closing this ticket as per OP's request.

Note: See TracTickets for help on using tickets.