Opened 7 years ago

Closed 7 years ago

Last modified 7 years ago

#4451 closed Bug (invalid)

Finished torrents go on being processed

Reported by: elpres Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.33
Severity: Normal Keywords:
Cc:

Description

Right now I have four torrents on the list, one running and three finished (done downloading and seeding; the bar is grey) and have been this way for quite a while (days to weeks). Transmission has been restarted a couple of times since (normal computer shutdowns, nothing special). Today I took a look into the log and noticed that these finished torrents are still loaded at start-up and announced to trackers and over DHT regularly, as though they were still active. Basically 3/4 of the log is about torrents that should have been "forgotten" after their seeding has completed.

Change History (5)

comment:1 Changed 7 years ago by livings124

Are the torrents paused or active? Are they announces or scrapes? Scrapes are initial and getting basic information for display.

comment:2 Changed 7 years ago by elpres

I would say they are paused, but not in the sense that I right clicked them and selected "Pause selected". They have been stopped automatically after reaching the selected seed ratio. The status line below their progress bar says "Seeding complete". As for the kind of activity, they are scrapes. I did a proper grep of the log and these are the first lines:

2011-08-28 17:26:05 +0200 resume.c:692 [Debug] {torrent name}: Read resume file "/Path/To/Filename.d74075f8e870775d.resume"
2011-08-28 17:26:06 +0200 resume.c:140 [Debug] {torrent name}: Loaded 169 IPv4 peers from resume file
2011-08-28 17:26:06 +0200 resume.c:147 [Debug] {torrent name}: Loaded 41 IPv6 peers from resume file
2011-08-28 17:26:06 +0200 resume.c:205 [Debug] {torrent name}: Resume file found 304 files marked for download
2011-08-28 17:26:06 +0200 bencode.c:1721 [Info] Transmission: Saved "Path/To/Filename.d74075f8e870775d.torrent"
2011-08-28 17:27:20 +0200 announcer.c:1214 [Info] {torrent name}: Scrape error: Could not connect to tracker
2011-08-28 17:27:20 +0200 announcer.c:1223 [Info] {torrent name}: Retrying scrape in 351 seconds.

Everything else that follows comes from "announcer.c" and is either a successful or failed scrape.

Before posting the bug report I only glanced over the log and had the impression that there have also been some announce entries, but now all I can confirm are scrapes. Looks like I should have taken a closer look before posting... But the scrapes are perhaps still unnecessary traffic that could be avoided?

On an unrelated note, thank you for the work you put into Transmission! I've been using it for years, never had any problems and love its uncluttered interface and low memory usage. Good luck to you in keeping it that way!

comment:3 Changed 7 years ago by livings124

  • Resolution set to invalid
  • Status changed from new to closed

Thanks!

Closing this as scrapes are minimal traffic and allowed per the bit torrent specs.

comment:4 Changed 7 years ago by x190

elpres, you might find the following trac ticket of interest. https://trac.transmissionbt.com/ticket/3219#comment:24

Also, are you withdrawing the "over DHT regularly, as though they were still active" part of this ticket?

comment:5 Changed 7 years ago by elpres

Yes, I do. At first I really had the impression that there were DHT related entries, but grepping the log showed that to be an overreaction.

The other ticket is very relevant, thanks for pointing it out.

Note: See TracTickets for help on using tickets.