Opened 10 years ago

Closed 10 years ago

#4452 closed Bug (fixed)

major Inspector > Files regression, and javascript errors in file-row.js

Reported by: gunzip Owned by: jordan
Priority: Normal Milestone:
Component: Web Client Version: 2.33+
Severity: Normal Keywords:
Cc:

Description

the web-client hasn't been usable for me in any of the recent builds. the last good build i believe was 12760. the Inspector > Files is now normally blank after adding a torrent, though sometimes if a play with it the files will eventually appear. also other actions like "Remove from List" are sporadic.

both FF 6.0 and Google Chrome 13 error consoles report same error when this occurs:

Error: file.name is undefined
Source File: http://localhost:9091/transmission/web/javascript/file-row.js
Line: 113

transmission-daemon 2.33+ (12787)

Attachments (1)

files.png (70.5 KB) - added by gunzip 10 years ago.

Download all attachments as: .zip

Change History (13)

comment:1 Changed 10 years ago by jordan

The 'file.name is undefined' error should be fixed now in r12791. What happens when you update and re-test?

comment:2 Changed 10 years ago by gunzip

with r12793 "file.name undefined" error is indeed gone, but still have problems with Inspector > Files. instead of blank in Files i see Unknown (see attached files.png). if i refresh the page the correct files do appear. but if i leave the page and come back to it, i have to refresh again.

similarly, "Remove from List" doesn't update unless you manually refresh the page.

Changed 10 years ago by gunzip

comment:3 Changed 10 years ago by jordan

gunzip, does r12797 solve this problem?

Please make sure & flush your browser's cache and force a full reload when testing. I've been bitten by this several times :)

A little background: the file lists take up a lot of memory, and when there is a large list of torrents, the memory use grows even faster. The files are *only* used in the inspector, so it makes sense to not request those fields (as well as tracker stats and peer info) until the details dialog is opened.

I'm not able to repeat the behavior you're seeing, so my guess is that the request asking for that extra info failed. r12797 changes the code s.t. if the request for that extra info fails, we keep retrying.

comment:4 follow-up: Changed 10 years ago by jordan

  • Milestone None Set deleted
  • Owner set to jordan
  • Status changed from new to assigned

"Remove from List" doesn't update unless you manually refresh the page.

Fixed in r12800.

comment:5 Changed 10 years ago by gunzip

Replying to jordan:

Please make sure & flush your browser's cache and force a full reload when testing. I've been bitten by this several times :)

yes i know what you mean and i've been careful to clear all browser cache before testing

A little background: the file lists take up a lot of memory, and when there is a large list of torrents, the memory use grows even faster. The files are *only* used in the inspector, so it makes sense to not request those fields (as well as tracker stats and peer info) until the details dialog is opened.

OK, but this inspector/file problem occurred for me even if only one small torrent was loaded, and it happened with both FF and Chrome.

I'm not able to repeat the behavior you're seeing, so my guess is that the request asking for that extra info failed. r12797 changes the code s.t. if the request for that extra info fails, we keep retrying.

gunzip, does r12797 solve this problem?

yes, now using r12799 and the file names appear automatically after a small fraction-of-second delay. looks good in both FF and Chrome when re-testing everything, and makes the web-interface usable again for me.

one new bug: the Pause / Resume buttons to the right of all torrents have become non-functional. however those actions still work fine from the Tool Bar. should i open a separate ticket for that?

comment:6 in reply to: ↑ 4 Changed 10 years ago by gunzip

Replying to jordan:

"Remove from List" doesn't update unless you manually refresh the page.

Fixed in r12800.

very good .. i upped to build 12800 and yes the issue is solved.

comment:7 Changed 10 years ago by jordan

the Pause / Resume buttons to the right of all torrents have become non-functional. however those actions still work fine from the Tool Bar.

Fixed in r12811. :)

comment:8 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

comment:9 Changed 10 years ago by gunzip

i'm still having nagging problems ( r12811 ), and for the first time FF and Chrome are giving divergent behavior.

Firefox 6.0: the Pause / Resume button is now working, but when i select (highlight) a torrent, it unselects itself so that the Inspector is unavailable. (the torrent only stays highlighted for about a second).

Chrome 13: A selected torrent does persist, however the Pause / Resume button remains non-functional.

Internet Explorer 8: just a heads up, but the web-interface is broken badly in a few tests i've done with a windows box.

comment:10 Changed 10 years ago by gunzip

  • Resolution fixed deleted
  • Status changed from closed to reopened

comment:11 follow-up: Changed 10 years ago by jordan

Both issues should be fixed now in r12816. NEXT! :)

comment:12 in reply to: ↑ 11 Changed 10 years ago by gunzip

  • Resolution set to fixed
  • Status changed from reopened to closed

Replying to jordan:

Both issues should be fixed now in r12816. NEXT! :)

yes that did it .. FF and Chrome are working well now

Note: See TracTickets for help on using tickets.