Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4458 closed Bug (fixed)

"transmission-edit -a" just overwrites the tracker

Reported by: MPW Owned by: jordan
Priority: Normal Milestone: 2.40
Component: Utils Version: 2.33
Severity: Normal Keywords: add tracker fails
Cc:

Description

When I want to edit a second tracker to a torrent file with

transmission-edit -a URL_of_new_Tracker torrentfile.torrent

it just overwrites the Tracker.

Version 2.55 (12565) from Ubuntu 11.04 repo.

Change History (5)

comment:1 Changed 10 years ago by jordan

Hi MPW,

Thanks for reporting this issue and helping to make Transmission better. I'm not able to reproduce this issue. Could you give me a walkthrough of the steps needed to trigger this?

Here's what I tried with a recent nightly build:

Before editing:

$ ./transmission-show ubuntu-11.04-desktop-i386.iso.torrent 
Name: ubuntu-11.04-desktop-i386.iso
File: ubuntu-11.04-desktop-i386.iso.torrent

GENERAL

  Name: ubuntu-11.04-desktop-i386.iso
  Hash: a38d02c287893842a32825aa866e00828a318f07
  Created by: 
  Created on: Thu Apr 28 03:35:26 2011
  Comment: Ubuntu CD releases.ubuntu.com
  Piece Count: 1371
  Piece Size: 512.0 KiB
  Total Size: 685.3 MiB
  Privacy: Public torrent

TRACKERS

  Tier #1
  http://torrent.ubuntu.com:6969/announce

  Tier #2
  http://ipv6.torrent.ubuntu.com:6969/announce

FILES

  ubuntu-11.04-desktop-i386.iso (685.3 MiB)

Adding a third tracker:

$ ./transmission-edit -a "http://www.example.com/announce" ubuntu-11.04-desktop-i386.iso.torrent 
ubuntu-11.04-desktop-i386.iso.torrent
	Added "http://www.example.com/announce" to "announce-list" tier 3
Changed 1 files

Result:

$ ./transmission-show -a ubuntu-11.04-desktop-i386.iso.torrent 
Name: ubuntu-11.04-desktop-i386.iso
File: ubuntu-11.04-desktop-i386.iso.torrent

GENERAL

  Name: ubuntu-11.04-desktop-i386.iso
  Hash: a38d02c287893842a32825aa866e00828a318f07
  Created by: 
  Created on: Thu Apr 28 03:35:26 2011
  Comment: Ubuntu CD releases.ubuntu.com
  Piece Count: 1371
  Piece Size: 512.0 KiB
  Total Size: 685.3 MiB
  Privacy: Public torrent

TRACKERS

  Tier #1
  http://torrent.ubuntu.com:6969/announce

  Tier #2
  http://ipv6.torrent.ubuntu.com:6969/announce

  Tier #3
  http://www.example.com/announce

FILES

  ubuntu-11.04-desktop-i386.iso (685.3 MiB)

comment:2 Changed 10 years ago by MPW

Hello,

sorry that I answer you that late. I see your point, but:

With the ubuntu-torrent it works for me, too. But try this one:

http://cdimage.debian.org/debian-cd/6.0.2.1/amd64/bt-cd/debian-6.0.2.1-amd64-CD-43.iso.torrent

The difference between the ubuntu torrent and this debian torrent is, that the ubuntu torrent already has 2 trackers. That means, that in bencode the trackers are stored in an array.

If a torrent has just one tracker like the debian one, transmission-edit has to change the data type from just a string to an array. And at this points tranmission-edit fails!

Try it again with the debian tracker please. For me, with version 2.33 (12565), this definitly fails!

Bye MPW

comment:3 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.40
  • Status changed from new to assigned

Yep, you're right. Thanks for the sample torrent.

comment:4 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed in r12851

comment:5 Changed 10 years ago by MPW

Thanks for the quick fix!

Note: See TracTickets for help on using tickets.