Opened 10 years ago

Closed 10 years ago

#4472 closed Enhancement (duplicate)

Option to disable speed limiting for private network IP ranges

Reported by: Harry Owned by:
Priority: Low Milestone: None Set
Component: Transmission Version: 2.33
Severity: Minor Keywords:
Cc: transmission@…

Description

There should be an option (default on?) to disable the speed throttling when sending data to private IP ranges. 10.0.0.0/8 172.16.0.0/12 192.168.0.0/16 and maybe fc00::/7 (though many people don't use ULA on their IPv6)

Most of the time you can get "unlimited" speed on these IP ranges as most of the time they are LAN connected. This allows for better speeds for everyone, as the non-local traffic won't get slowed down by the local traffic. Some clients such as uT have this feature and I enjoy to use it a lot.

The setting can always be kept off if the user doesn't desire it.

Another thing might be associated with this idea, would to be able to whitelist IP ranges to give unlimited/priority speed to; but I don't think that will be done due to neutrality issues...

Thanks.

Change History (4)

comment:1 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #3076

comment:2 Changed 10 years ago by tman

3076 is also closed, this ticket should be reopened, I would like a lot to have this feature. I have 4 peers in my local network, it would be nice to have unlimited badwidth with them.

comment:3 Changed 10 years ago by tman

  • Resolution duplicate deleted
  • Status changed from closed to reopened

comment:4 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from reopened to closed

The tickets cover the same feature; this is a duplicate.

Note: See TracTickets for help on using tickets.