Opened 10 years ago

Closed 10 years ago

#4474 closed Bug (duplicate)

transmission-daemon crashes on web request

Reported by: Volfram Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.33
Severity: Normal Keywords: core daemon web
Cc:

Description

OS: Arch Linux x64

Crashes upon first request to web interface ( *:9091 ), core dump can be downloaded from [dicebot.lv/transmission-core]

[root@dicebot http]# transmission-daemon --log-error --log-info --log-debug -g /root/.config/transmission-daemon/ -f [06:16:45.014] Transmission 2.33 (12565) started (session.c:704) [06:16:45.015] Couldn't read "/root/.config/transmission-daemonstats.json": No such file or directory (utils.c:443) [06:16:45.015] Couldn't read "/root/.config/transmission-daemonstats.benc": No such file or directory (utils.c:443) [06:16:45.015] Cache Maximum cache size set to 4.00 MiB (256 blocks) (cache.c:258) [06:16:45.015] RPC Server Adding address to whitelist: 127.0.0.1 (rpc-server.c:805) [06:16:45.015] RPC Server Serving RPC and Web requests on port 127.0.0.1:9091/transmission/ (rpc-server.c:999) [06:16:45.015] RPC Server Password required (rpc-server.c:1006) [06:16:45.015] Bound socket 11 to port 51413 on 0.0.0.0 (net.c:373) [06:16:45.015] Bound socket 12 to port 51413 on :: (net.c:373) [06:16:45.015] Port Forwarding Stopped (port-forwarding.c:181) [06:16:45.015] DHT Initializing DHT (tr-dht.c:276) [06:16:45.015] Couldn't read "/root/.config/transmission-daemondht.dat": No such file or directory (utils.c:443) [06:16:45.015] DHT Generating new id (tr-dht.c:309) [06:16:45.015] DHT DHT initialized (tr-dht.c:330) [06:16:45.015] Using settings from "/root/.config/transmission-daemon/" (daemon.c:488) [06:16:45.015] Saved "/root/.config/transmission-daemon/settings.json" (bencode.c:1721) [06:16:45.015] transmission-daemon requiring authentication (daemon.c:508) Segmentation fault (core dumped)

Core was generated by `transmission-daemon --log-error --log-info --log-debug -g /root/.config/transmi'. Program terminated with signal 11, Segmentation fault. #0 0x00007fdc04a92f43 in memcpy () from /lib/libc.so.6 (gdb) bt #0 0x00007fdc04a92f43 in memcpy () from /lib/libc.so.6 #1 0x000000000042af9e in ?? () #2 0x00000000004399ca in ?? () #3 0x00007fdc057e8ba5 in ?? () from /usr/lib/libevent-2.0.so.5 #4 0x00007fdc057e7cd1 in ?? () from /usr/lib/libevent-2.0.so.5 #5 0x00007fdc057d819d in ?? () from /usr/lib/libevent-2.0.so.5 #6 0x00007fdc057cc5cc in event_base_loop () from /usr/lib/libevent-2.0.so.5 #7 0x000000000041de40 in ?? () #8 0x000000000040f75a in ?? () #9 0x00007fdc04d75d60 in start_thread () from /lib/libpthread.so.0 #10 0x00007fdc04ae125d in clone () from /lib/libc.so.6 #11 0x0000000000000000 in ?? ()

Change History (1)

comment:1 Changed 10 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed

Closing as a duplicate of #4473

Note: See TracTickets for help on using tickets.