Opened 10 years ago

Closed 8 years ago

#4484 closed Bug (duplicate)

Queued torrents are stopped after daemon restart

Reported by: KyleK Owned by: jordan
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.40
Severity: Normal Keywords:
Cc: vitorg@…, hgabreu@…, klangga@…, noone3@…

Description

I have queuing enabled in the latest nightly (svn 12865), download-queue-size is set to 4.

I added 6 torrents to an otherwise "empty" daemon, and 4 started downloading immediately, while the other two showed as "Queued" in transmission-remote.

After stopping the daemon and later restarting it, the 4 files that were previously downloading did so again, while the other 2 items were shown as "Stopped".

Removing (or manually stopping) any of the 4 downloading torrents did not result in the other, "idle" files starting to download.

Change History (10)

comment:1 Changed 10 years ago by KyleK

Just tested this again with a vanilla compile of 2.40b2 and the problem still exists?

Does anyone else experience this? I reckon this should be fixed for 2.40 final, since queuing is a rather big feature in this release.

comment:3 Changed 10 years ago by vitorg

  • Cc vitorg@… added

Using 2.42 - got the same issue, very annoying because my NAS rebooted every night and all queued downloads becomes paused.

comment:4 Changed 10 years ago by hgabreu

  • Cc hgabreu@… added

I have this issue too, but not using the deamon, I use transmission-gtk v2.5 on linux. I came to this ticket from the discussion on #4540, where someone (rb07) stated that the issue is on libtransmission.

By the way, I don't see this topic anywhere else, and I'm not sure if it's tightly related, but the queue order is also not preserved between restarts. i.e. if you change the queue order, exit and re-open transmission it is totally lost.

comment:5 Changed 10 years ago by zang3tsu

  • Cc klangga@… added

comment:6 Changed 10 years ago by jordan

  • Owner set to jordan
  • Status changed from new to assigned

comment:7 Changed 9 years ago by dskchk

  • Cc noone3@… added

comment:8 Changed 9 years ago by jordan

  • Version changed from 2.33+ to 2.40

comment:9 Changed 9 years ago by user967

"Finished" state is also not preserved.

comment:10 Changed 8 years ago by dale2507

Any progress on this? I have to turn transmission off through the day so this is a rather big problem.

comment:11 Changed 8 years ago by jordan

  • Resolution set to duplicate
  • Status changed from assigned to closed

This looks like the same issue that was just fixed in bug #5427

Note: See TracTickets for help on using tickets.