Opened 10 years ago

Closed 10 years ago

#4505 closed Enhancement (duplicate)

Multiple schedule entries

Reported by: Renara Owned by: livings124
Priority: Normal Milestone: None Set
Component: Mac Client Version: 2.33
Severity: Normal Keywords:
Cc:

Description

Fairly simple idea. Basically the idea is to expand the single speed-limit schedule to allow multiple schedules to be provided.

The reason I ask for this is that my ISP seems to have quietly added really terrible "traffic management" restrictions with different restrictions for download and upload, and all at different times, just to make things really annoying.

Anyway, the idea is to allow for a list of scheduled speed restrictions, allowing download and upload speed changes to be schedule independently. Also allowing for different restrictions so (for example) I could set unlimited speeds during the dead periods such as 10pm to 10am, but then put a modest restriction on during off-peak between 10am and 4pm, then a stricter limit during peak time at 4pm to 10pm.

This should be do-able with a simple list with boxes at the side, click an item in the list to fill the boxes for editing, or add a new entry. Each entry has a start time, and a limit on at least one of download and upload speed. Possible values include either a fixed rate (e.g - 10kbps) or may be set to unlimited, otherwise, if left blank, then any previously set value will be used. To set the speed-limit button, you would then select one or more rows to set as the speed-limit settings, causing them to take effect immediately and stay in effect until the manual speed-limit is disabled. Otherwise they will be schedule normally.

Another, simpler alternative would be to simply have speed settings with options to specify two (normal and peak) or three (normal, off-peak, peak) settings.

Change History (1)

comment:1 Changed 10 years ago by livings124

  • Resolution set to duplicate
  • Status changed from new to closed

The is a duplicate of #2893.

Note: See TracTickets for help on using tickets.