Opened 10 years ago

Closed 10 years ago

#4507 closed Bug (fixed)

scrape min_request_interval no longer working?

Reported by: reardon Owned by: jordan
Priority: Normal Milestone: 2.40
Component: libtransmission Version: 2.33
Severity: Normal Keywords:
Cc:

Description

sometime since changeset#8581 the handling of this got mangled. It used to be in tracker.c, now it's in announcer-http.c

The problem is that the parsing for the flags{} dict was lost. The only trackers I know of that report min_request_interval during a scrape always put it inside the flags{} dict.

see also: http://wiki.theory.org/BitTorrentSpecification#Tracker_Response

Change History (2)

comment:1 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.40
  • Status changed from new to assigned
  • Summary changed from min_request_interval no longer working? to scrape min_request_interval no longer working?

comment:2 Changed 10 years ago by jordan

  • Resolution set to fixed
  • Status changed from assigned to closed

Fixed for 2.40 by r12914.

Thanks for reporting this, reardon!

Note: See TracTickets for help on using tickets.