Opened 10 years ago

Closed 10 years ago

#4519 closed Bug (worksforme)

speed-limit-down not followed

Reported by: Harry Owned by:
Priority: Normal Milestone: None Set
Component: Daemon Version: 2.33+
Severity: Normal Keywords:
Cc:

Description

Download limits aren't being followed for me.

I have speed-limit-down configured at 1000, however it's downloading at 1,60 MB/s (which is the maximum speed my connection goes). speed-limit-down-enabled=true as well. I am pretty sure it's not overhead, as if I set my limits to 5 kb/s it still does at 1,60 MB/s.

I am using the SVN version on Ubuntu 10.04.

Attachments (2)

screenie.png (39.4 KB) - added by Harry 10 years ago.
screenshot for transmission
settings.json (2.2 KB) - added by Harry 10 years ago.
my settings

Download all attachments as: .zip

Change History (7)

Changed 10 years ago by Harry

screenshot for transmission

Changed 10 years ago by Harry

my settings

comment:1 follow-up: Changed 10 years ago by livings124

settings.json has "speed-limit-down": 1500

comment:2 in reply to: ↑ 1 Changed 10 years ago by Harry

Replying to livings124:

settings.json has "speed-limit-down": 1500

I have it configured in the web client to even lower though. Bug still stands. (and even if it was running at 1500, I don't think any overhead would make it hit 1,60MB/s, and I also tested after making speed-limit-down:5.

comment:3 Changed 10 years ago by jordan

I'm a little confused about this ticket -- so far we've got limits of 5 KB/s, 1000 KB/s, and 1500 KB/s on the table.

Could you for me the steps I need to recreate this issue starting from a clean slate session with no torrents and a default settings.json?

comment:4 Changed 10 years ago by Harry

What's your maximum Internet speed? If it's pretty fast then you should be able to reproduce it with making your speed limit at 5 KB/s, then downloading a torrent such as an Ubuntu ISO. If that doesn't reproduce for you, try to use the attached config earlier.

In either case I can't seem to reproduce it anymore. I think it was a regression that r12932 fixed.

comment:5 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed

I don't really understanding what this ticket's saying, but fixed is fixed.

Note: See TracTickets for help on using tickets.