Opened 7 years ago

Last modified 3 years ago

#4545 reopened Bug

Transmission needs to verify local data after "Set Location"

Reported by: crocket Owned by:
Priority: Normal Milestone: None Set
Component: Transmission Version: 2.33
Severity: Normal Keywords:
Cc: ewtoombs@…, ed.linklater@…

Description

Other clients verify local data before they start downloading, so they don't overwrite on already existing data when I give them a new torrent which is to be downloaded on a place where data exists.

However, transmission doesn't automatically check local data before downloading and downloads on top of existing data unless I manually have it check local data.

If transmission verified local data whenever it needed to, users would have less headache in their lives.

I think there could be some points where veriying local data is beneficial. 1) after a torrent is added but before a torrent starts downloading 2) etc...

Change History (15)

comment:1 Changed 7 years ago by jordan

  • Version changed from 2.33+ to 2.33

comment:2 Changed 7 years ago by crocket

Actually, transmission verifies local data when it adds a new torrent to the default download folder. So it was my mistake. But when I set another non-default location for a torrent with "Set Location" and there is already 100% of data, transmission doesn't automatically verify local data and is happy to overwrite on existing data.

transmission should automatically verify after "Set Location".

comment:3 Changed 7 years ago by jordan

  • Summary changed from Transmission needs to verify local data before downloading. to Transmission needs to verify local data after "Set Location"

comment:4 Changed 7 years ago by jordan

ticket #4567 has been closed as a duplicate of this ticket.

comment:5 Changed 6 years ago by ewtoombs

  • Cc ewtoombs@… added
  • Type changed from Enhancement to Bug

I have the same problem. This is pretty serious. I wouldn't call this a mere enhancement when this is what any sane client should do. I'm changing this to a bug.

comment:6 Changed 5 years ago by spaz926

Came on to report this. Glad I found the same problem. I have been automatically adding and starting torrents when the .torrent file is added to my downloads folder. I downloaded a linux distro last night and when I thought I didn't need it I removed the torrent from Transmission. Turned out I actually did need it and so I downloaded it again today only to see the torrent restarting. I had to manually uncheck the "only if" options and manually verify local data before it realized half of the file was already there. Transmission needs to verify local data on import by default even when automatically added.

comment:7 Changed 5 years ago by cryptochrome

  • Priority changed from Normal to High
  • Version changed from 2.33 to 2.82+

I just stumbeled across the same issue. I am kind of puzzeled that this hasn't been touched in the 2 years since this ticket has been opened.

Is anyone from the devs looking at this?

comment:8 Changed 5 years ago by jordan

  • Priority changed from High to Normal
  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 2.82+ to 2.33

Looks like bug #4649 is a duplicate of this ticket.

However, I'm going to close this one as #4649 is seeing more action and has a patch developing.

comment:9 Changed 5 years ago by crocket

jordan : How can this be a duplicate of #4649?

I read #4649, and #4649 doesn't seem to be involve with "set location" nor with verification of data "before" a torrent starts.

#4649 is about verification of data "after" a torrent completes.

I need an explanation.

comment:10 Changed 5 years ago by cryptochrome

  • Resolution duplicate deleted
  • Status changed from closed to reopened

Actually, this does not seem to be a duplicate of #4649. 4649 is about generally doing a local verify upon download completion. This ticket here is about Transmission not verifying local data when adding a torrent that has previsouly been downloaded and the data is already there. Two completely different issues!

comment:11 Changed 5 years ago by x190

---

Last edited 5 years ago by x190 (previous) (diff)

comment:12 follow-up: Changed 5 years ago by crocket

How do I test the patch?

comment:13 in reply to: ↑ 12 Changed 5 years ago by x190

Replying to crocket:

How do I test the patch?

Not ready for testing! :-\

Last edited 5 years ago by x190 (previous) (diff)

comment:14 Changed 4 years ago by edlinklater

  • Cc ed.linklater@… added

comment:15 Changed 3 years ago by ant75

Just experienced this bug in Transmission. Didn't realize what was going on! I used to use uTorrent on my windows PC but are now switching to Transmission which runs in my router. When I added the torrents they would start to verify but if the router crashed or reset for some reason then they would just sit stopped when the router was back up. If I clicked on them to manually start them they would not automatically verify but would start to re-download entirely from start! I found that I had to manually click verify to get them to use the downloaded data. Crazy...

We need Transmission to automatically manage all this! Other clients do it right. uTorrent did! Transmission needs to automatically verify and start this process after being restarted. Its useless to have the Torrents all sitting like dead ducks and doing nothing because we haven't manually clicked on verify! And to think that if we click on start instead of verify that the whole thing re-downloads..... What?

Seems like a long time to wait for a reasonably simple bug? What gives?

Note: See TracTickets for help on using tickets.