Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4550 closed Bug (fixed)

Changelog advertise gtk3 support but there isn't any way to build it

Reported by: wonder Owned by: jordan
Priority: Normal Milestone: 2.42
Component: GTK+ Client Version: 2.40
Severity: Normal Keywords:
Cc:

Description

If is true, configure.ac is missing a check for gtk-3.0 and the only available version is gtk-2.0 >= 2.22.0

Change History (9)

comment:1 Changed 10 years ago by jordan

  • Component changed from Transmission to GTK+ Client
  • Owner set to jordan

comment:2 Changed 10 years ago by jordan

  • Milestone changed from None Set to 2.50
  • Status changed from new to assigned

This should be working now after r12964.

comment:3 Changed 10 years ago by jordan

  • Keywords backport-2.4x added
  • Resolution set to fixed
  • Status changed from assigned to closed

comment:5 Changed 10 years ago by KyleK

Due to the changes from this ticket, configure fails for me because it can't find GTK. This is even though I want to build a headless Transmission only.

The option "--without-gtk" is of no help. I looked at the configure source code, it will always fail of GTK is not present. It will even fail if you don't have pkg-config, but specify the configure options GTK(2|3)_CFLAGS and GTK(2|3)_LIBS.

comment:6 Changed 10 years ago by jordan

  • Milestone changed from 2.50 to 2.42

comment:7 Changed 10 years ago by jordan

backported to 2.4x in r13006

comment:8 Changed 10 years ago by jordan

  • Version changed from 2.41 to 2.40

comment:9 Changed 10 years ago by jordan

  • Keywords backport-2.4x removed
Note: See TracTickets for help on using tickets.