Opened 10 years ago

Closed 10 years ago

#4551 closed Bug (worksforme)

Crash when opening properties in gtk3 version.

Reported by: Mad Fish Owned by: jordan
Priority: Normal Milestone: None Set
Component: GTK+ Client Version: 2.41
Severity: Major Keywords:
Cc:

Description

Reproducible almost always.

Backtrace:

#0  0x00007ffff6b51580 in g_type_check_instance_cast () from /usr/lib/libgobject-2.0.so.0
#1  0x00000000004301b4 in rowNew (w=0x2930240) at hig.c:66
#2  0x00000000004304e7 in hig_workarea_add_label_w (t=0x2aa15f0, row=2, l=0x2930240) at hig.c:116
#3  0x00000000004307c6 in hig_workarea_add_row_w (t=0x2aa15f0, row=0x7fffffffd26c, label=0x2930240, control=0xb42350, mnemonic=0x0) at hig.c:161
#4  0x0000000000445316 in bandwidthPage (core=0x766810) at tr-prefs.c:1071
#5  0x000000000044617b in gtr_prefs_dialog_new (parent=0x9c2e50, core=0x766810) at tr-prefs.c:1285
#6  0x000000000043508c in gtr_actions_handler (action_name=0x7e1769 "edit-preferences", user_data=0x7fffffffe650) at main.c:1549
#7  0x00000000004213df in action_cb (a=0x9d0940, user_data=0x7fffffffe650) at actions.c:40
#8  0x00007ffff6b2d0e4 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#9  0x00007ffff6b3f06a in ?? () from /usr/lib/libgobject-2.0.so.0
#10 0x00007ffff6b486f1 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#11 0x00007ffff6b48892 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#12 0x00007ffff780b083 in ?? () from /usr/lib/libgtk-3.so.0
#13 0x00007ffff6b2d0e4 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#14 0x00007ffff6b3e85a in ?? () from /usr/lib/libgobject-2.0.so.0
#15 0x00007ffff6b486f1 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#16 0x00007ffff6b48892 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#17 0x00007ffff7a1455e in gtk_widget_activate () from /usr/lib/libgtk-3.so.0
#18 0x00007ffff78fd1fe in gtk_menu_shell_activate_item () from /usr/lib/libgtk-3.so.0
#19 0x00007ffff78fd593 in ?? () from /usr/lib/libgtk-3.so.0
#20 0x00007ffff78e87c8 in ?? () from /usr/lib/libgtk-3.so.0
#21 0x00007ffff6b2d0e4 in g_closure_invoke () from /usr/lib/libgobject-2.0.so.0
#22 0x00007ffff6b3ee9f in ?? () from /usr/lib/libgobject-2.0.so.0
#23 0x00007ffff6b484c3 in g_signal_emit_valist () from /usr/lib/libgobject-2.0.so.0
#24 0x00007ffff6b48892 in g_signal_emit () from /usr/lib/libgobject-2.0.so.0
#25 0x00007ffff7a15199 in ?? () from /usr/lib/libgtk-3.so.0
#26 0x00007ffff78e7faa in gtk_propagate_event () from /usr/lib/libgtk-3.so.0
#27 0x00007ffff78e83ab in gtk_main_do_event () from /usr/lib/libgtk-3.so.0
#28 0x00007ffff7562122 in ?? () from /usr/lib/libgdk-3.so.0
#29 0x00007ffff646085d in g_main_context_dispatch () from /usr/lib/libglib-2.0.so.0
#30 0x00007ffff6461058 in ?? () from /usr/lib/libglib-2.0.so.0
#31 0x00007ffff6461592 in g_main_loop_run () from /usr/lib/libglib-2.0.so.0
#32 0x00007ffff6e038de in g_application_run () from /usr/lib/libgio-2.0.so.0
#33 0x0000000000432853 in main (argc=1, argv=0x7fffffffe888) at main.c:644

Change History (5)

comment:1 follow-up: Changed 10 years ago by jordan

Hi Mad Fish,

Thanks for reporting this problem and helping to make Transmission better.

Are you using GTK+ 3.2 or higher?

Could you try building a nightly tarball of from https://build.transmissionbt.com/job/trunk-linux/ to see if the problem persists? If so, could you attach a backtrace from the nightly build in this ticket?

comment:2 Changed 10 years ago by Mad Fish

Yes, using GTK+ 3.2 (ArchLinux? package). Built gtk3 version by making this change: http://paste.kde.org/132211/raw/. Actually, this was already svn trunk version. I probably should check on released (2.41) version as well.

comment:3 in reply to: ↑ 1 Changed 10 years ago by Hairy

just thought id say, opening properties seems to be fine on the gtk3 client i just built from svn, against gtk3.2.0

comment:4 Changed 10 years ago by Mad Fish

2.41 seems to be fine, and updated svn version seems to be fine as well now. So I guess we can close this. I'm not sure which commit fixed the issue though.

comment:5 Changed 10 years ago by livings124

  • Resolution set to worksforme
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.