Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4554 closed Bug (fixed)

Transmission GTK client crashes on start

Reported by: Photon Owned by: jordan
Priority: Normal Milestone: 2.42
Component: GTK+ Client Version: 2.41
Severity: Critical Keywords:
Cc:

Description

transmission-gtk fails to start with a segmentation fault. transmission-daemon can be started and you can connect to it via web interface, but the download/upload list is empty. Starting transmission-gtk with empty .config and .cache dirs works, but adding a torrent produces a segfault again. See also https://bugs.archlinux.org/task/26391

Backtrace attached.

Attachments (1)

trace.log (6.8 KB) - added by Photon 10 years ago.

Download all attachments as: .zip

Change History (9)

Changed 10 years ago by Photon

comment:1 Changed 10 years ago by jordan

Hi Photon,

This is possibly fixed in r12971. Could you try a build from SVN or a nightly tarball from https://build.transmissionbt.com/job/trunk-linux/ and see if it fixes the problem?

comment:2 Changed 10 years ago by Photon

The crash persists, but the trace look different, I think. New trace attached.

comment:3 Changed 10 years ago by jordan

trac's moderator module won't let me approve the new trace b/c it's got a duplicate filename, but I think I see the problem anyway :)

Care to try a third time, with r12973 or higher?

comment:4 Changed 10 years ago by nemesis2all

Had the same issue as Photon. Installed r12979 and the issue is resolved.

comment:5 Changed 10 years ago by Photon

  • Resolution set to fixed
  • Status changed from new to closed

The bug seems to be fixed, thanks!

comment:6 Changed 10 years ago by livings124

  • Keywords backport-2.4x added; segfault removed
  • Milestone changed from None Set to 2.50

comment:7 Changed 10 years ago by Photon

Sorry, that's me again. :) As I see, the fix will be backported to 2.4x. When is a release of a version including the fix planned? Or maybe the fix can be applied in the distribution packages temporarily? If so, which changes should be included into a patch?

Thanks, Photon

comment:8 Changed 10 years ago by jordan

  • Keywords backport-2.4x removed
  • Milestone changed from 2.50 to 2.42

backported to the 2.4x branch for 2.42 by r12998

Photon: 2.42 will be out shortly.

Note: See TracTickets for help on using tickets.