Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4560 closed Bug (worksforme)

Unable to check "Preferences->Network->"Enable uTP for peer communication"

Reported by: leandroong Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.41
Severity: Normal Keywords:
Cc:

Description

Version used: 2.40+_12979 Default state: uncheck. Problem: checking it will auto uncheck. Why?

Change History (16)

comment:1 Changed 10 years ago by jordan

  • Version changed from 2.41+ to 2.41

comment:2 Changed 10 years ago by livings124

I'm not seeing this in conjunction with the Mac client in r12992. Is this still occurring, and what OS/version are you using?

comment:3 Changed 10 years ago by leandroong

tomato router, linux OS access via win7 using web-client Restested again, 2.41+_12988. No problem on IE8. But, problem persist on firefox 7.1.

comment:4 Changed 10 years ago by livings124

Is there some sort of error console for webpages in Firefox?

comment:5 Changed 10 years ago by leandroong

No error console. Initially checkbox is uncheck. I check it, it would momemtarily display check then back to unchecked.

comment:6 Changed 10 years ago by cfpp2p

v2.42 (13013)

I get the same thing with rpc because return result is ALWAYS false. But actually "utp-enabled": IS being changed but you just can't see it because return ALWAYS shows false. I kill transmission-daemeon to check settings.json "utp-enabled": and each time it is indeed changed, so problem is return !always! shows false. Check it out, you'll see...

{"tag":3,"method":"session-set","arguments":{"peer-port":51413,"port-forwarding-enabled":false,"pex-enabled":true,"peer-limit-global":60,"peer-limit-per-torrent":60,"cache-size-mb":4,"blocklist-url":"http://www.example.com/blocklist","encryption":"preferred","speed-limit-up-enabled":false,"speed-limit-up":10,"speed-limit-down-enabled":false,"speed-limit-down":50,"alt-speed-enabled":false,"alt-speed-down":50,"alt-speed-up":50,"alt-speed-time-enabled":false,"alt-speed-time-begin":540,"alt-speed-time-end":1020,"blocklist-enabled":false,"seedRatioLimited":false,"seedRatioLimit":2,"idle-seeding-limit-enabled":false,"idle-seeding-limit":30,"incomplete-dir-enabled":false,"incomplete-dir":"/root/Downloads","dht-enabled":true,"lpd-enabled":false,"utp-enabled":true,"rename-partial-files":false,"download-dir":"/share/hdd/data/16gb/"}}

{"arguments":{"alt-speed-down":50,"alt-speed-enabled":false,"alt-speed-time-begin":540,"alt-speed-time-day":2,"alt-speed-time-enabled":false,"alt-speed-time-end":1020,"alt-speed-up":50,"blocklist-enabled":false,"blocklist-size":0,"blocklist-url":"http://www.example.com/blocklist","cache-size-mb":4,"config-dir":"/root/.config/transmission-daemon","dht-enabled":true,"download-dir":"/share/hdd/data/16gb/","download-dir-free-space":4288791552,"download-queue-enabled":true,"download-queue-size":1,"encryption":"preferred","idle-seeding-limit":30,"idle-seeding-limit-enabled":false,"incomplete-dir":"/root/Downloads","incomplete-dir-enabled":false,"lpd-enabled":false,"peer-limit-global":60,"peer-limit-per-torrent":60,"peer-port":51413,"peer-port-random-on-start":false,"pex-enabled":true,"port-forwarding-enabled":false,"queue-stalled-enabled":true,"queue-stalled-minutes":30,"rename-partial-files":false,"rpc-version":14,"rpc-version-minimum":1,"script-torrent-done-enabled":false,"script-torrent-done-filename":"","seed-queue-enabled":false,"seed-queue-size":1,"seedRatioLimit":2,"seedRatioLimited":false,"speed-limit-down":50,"speed-limit-down-enabled":false,"speed-limit-up":10,"speed-limit-up-enabled":false,"start-added-torrents":true,"trash-original-torrent-files":false,"units":{"memory-bytes":1024,"memory-units":["KiB","MiB","GiB","TiB"],"size-bytes":1024,"size-units":["KiB","MiB","GiB","TiB"],"speed-bytes":1024,"speed-units":["KiB/s","MiB/s","GiB/s","TiB/s"]},"utp-enabled":false,"version":"2.42 (13013)"},"result":"success","tag":0}

comment:7 Changed 10 years ago by jordan

My guess is that your copies of Transmission were compiled without UTP support. The "utp-enabled" argument in RPC comes from tr_sessionIsUTPEnabled(), which is implemented this way:

bool
tr_sessionIsUTPEnabled( const tr_session * session )
{
    assert( tr_isSession( session ) );

#ifdef WITH_UTP
    return session->isUTPEnabled;
#else
    return false;
#endif
}

comment:8 Changed 10 years ago by leandroong

How do I know if i'm compiling with UTP?

comment:9 Changed 10 years ago by jordan

configure.sh will say so. After the tests run, the summary will say something like this:

   Build libtransmission:                             yes
      * optimized for low-resource systems:           no
      * µTP enabled:                                  yes

comment:10 Changed 10 years ago by leandroong

Configuration:

Source code location: . Compiler: g++

Build libtransmission: yes

  • optimized for low-resource systems: no
  • µTP enabled: yes

Build Command-Line client: yes

Build GTK+ client: yes (GTK+ 2)

  • libappindicator for an Ubuntu-style tray: yes

Build Daemon: yes

Build Mac client: no

comment:11 Changed 10 years ago by leandroong

My apology. You are right. Compilation using transmission.mk were compiled without utp support. I saw it in the summary. Could you tell me how to enable it? running ./configure did say that it is enabled.

comment:12 Changed 10 years ago by jordan

If you specify --with-utp=yes or --with-utp=no when invoking configure, the build will us that value. Otherwise, the fallback is to include uTP if this test passes: AC_CHECK_PROG([HAVE_CXX],[$CXX],[yes],[no])

transmission.mk isn't coming from transmissionbt.com, so I don't know what settings it uses, such as whether it enables UTP or not.

comment:13 Changed 10 years ago by leandroong

I did try to include that in transmission.mk, adding "--with-utp=yes". Result is still utp not enabled.

comment:14 Changed 10 years ago by jordan

If you're looking for help with transmission.mk, you'll need to ask downstream. I've never seen/read transmission.mk before and those questions are probably better asked to the people who wrote or maintain it.

comment:15 Changed 10 years ago by jordan

  • Resolution set to worksforme
  • Status changed from new to closed

I've confirmed that uTP toggling Works For Me when the daemon is built with uTP enabled, so this discussion seems to be moving form "bug report" to "support" wrt transmission.mk and building with uTP enabled. So I'm closing this bug report for now -- unless there is a bug here, this discussion should take place either downstream or in the transmission forums.

comment:16 Changed 10 years ago by cfpp2p

related discussion at Ticket #4604 with transmission.mk info

Note: See TracTickets for help on using tickets.