Opened 11 years ago

Closed 11 years ago

Last modified 11 years ago

#4564 closed Bug (fixed)

IE7 broken

Reported by: reardon Owned by:
Priority: Low Milestone: 2.42
Component: Web Client Version: 2.41
Severity: Normal Keywords:
Cc:

Description

Not sure if you want to spend any energy on this, but IE7 is not working at all for me. That is regardless of the recent change to fix IE8/9. The ie7.css stylesheet loads properly, but the client doesn't seem to handle anything beyond that. the TransmissionRemote? object seems to not work.

Change History (6)

comment:1 Changed 11 years ago by jordan

Are there any error messages in the javascript console?

comment:2 Changed 11 years ago by reardon

IE7 doesn't have a console like IE8/9. There is a cryptic parse error reported:

Line: 27
Char: 3
Error: 'TransmissionRemote' is undefined
Code: 0
URL: https://SERVER.DOMAIN/transmission/web

Note that issue occurs over http or https

comment:3 Changed 11 years ago by reardon

Actually there are four errors. The problem is that it's near impossible to figure which script is causing them.

1:

Line: 118
Char: 4
Error: Expected identifier, string or number
Code: 0
URL: https://SERVER.DOMAIN/transmission/web

2:

Line: 381
Char: 1
Error: Expected identifier, string or number
Code: 0
URL: AS ABOVE

3:

Line: 307
Char: 2
Error: Expected identifier, string or number
Code: 0
URL: AS ABOVE

4:

Line: 27
Char: 3
Error: 'TransmissionRemote' is undefined
Code: 0 
URL: AS ABOVE

comment:4 Changed 11 years ago by jordan

Well, this gave me a good excuse to give VirtualBox a try.

The TransmissionRemote issue is fixed in r12986 but there are still some strange stylesheet issues.

Last edited 11 years ago by jordan (previous) (diff)

comment:5 Changed 11 years ago by jordan

  • Milestone changed from None Set to 2.50
  • Priority changed from Normal to Low
  • Resolution set to fixed
  • Status changed from new to closed

The stylesheet issues I mentioned in the last comment don't exist in IE8.

If you want to submit a patch for the rest I'll happily consider using it, but IMO IE7 is not a high priority.

comment:6 Changed 11 years ago by jordan

  • Milestone changed from 2.50 to 2.42

Backported to the 2.4x/ branch for 2.42 by r13000

Note: See TracTickets for help on using tickets.