Opened 10 years ago

Closed 6 years ago

#4572 closed Enhancement (duplicate)

Web GUI - Unable to trash and remove torrents from touch devices

Reported by: shirre Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.41
Severity: Normal Keywords: feature-disparity trash web gui buttons
Cc:

Description

When using the web GUI on a computer with a mouse torrents can be trashed and removed by right clicking on transfers. When viewing the web GUI on a touch device, such as iPhone or iPad, no context menu is available and the only option is to simply remove transfers using the menu button. An (option for an) additional button should be added to the menu so that transfers can be trashed from touch devices.

Change History (8)

comment:1 Changed 10 years ago by jordan

  • Keywords feature-disparity added
  • Type changed from Bug to Enhancement

comment:2 Changed 9 years ago by killemov

A right-click is usually equivalent to a touch-and-hold action. So is this something specific to Transmission?

comment:3 Changed 9 years ago by shirre

Not sure about how other web apps respond to touch-and-hold, but it doesn't work in Transmission at least.

comment:4 Changed 9 years ago by poserdonut

Hi!

I've made some modifications to the web ui so there's an extra button in the toolbar that you can use to trash a torrent. I made this to be able to delete torrents from my ipad. So, it's no context menu but it enables you to trash torrents in some way.

Would this be interesting to put into the ui?

comment:5 Changed 9 years ago by shirre

Hey poserdonut, that sounds perfect! Would be great if you could commit this to the project.

comment:6 Changed 7 years ago by verysofttoiletpaper

Patch for a toolbar button: https://dpaste.de/89sz

comment:7 Changed 6 years ago by mike.dld

Duplicate of #5006 which has a patch.

comment:8 Changed 6 years ago by mike.dld

  • Resolution set to duplicate
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.