Opened 10 years ago

Closed 10 years ago

Last modified 10 years ago

#4576 closed Bug (fixed)

Webseed works with filenames not correctly

Reported by: alex73 Owned by:
Priority: Normal Milestone: 2.50
Component: Transmission Version: 2.41
Severity: Normal Keywords: webseed redirection
Cc:

Description

I created torrent-file with webseed. Webseed's address just an URL of my server, which redirects to the real file storage.

For example, webseed is http://alex73.../file1, which redirects to http://storage/zzz2 with 302 code.

Transmission downloads this file again and again and never stopped. Seems to problem with filename after redirection, because if I use the same name for redirected file, it transferred good.

Attachments (3)

t1.torrent (1.5 KB) - added by alex73 10 years ago.
Torrent file which never stopped
15o0mrBxlts12zbUo303gC.torrent (19.9 KB) - added by cfpp2p 10 years ago.
t1-bug.torrent (19.9 KB) - added by cfpp2p 10 years ago.

Download all attachments as: .zip

Change History (17)

Changed 10 years ago by alex73

Torrent file which never stopped

comment:1 Changed 10 years ago by cfpp2p

!!! Confirmed !!!

also continues downloading even when torrent is STOPPED

downloading shows speed higher than maximum bandwidth???

.

continues downloading even when torrent is manually VERIFIED

downloading shows speed higher than maximum bandwidth

shortly thereafter transmission CRASHES...

_

comment:2 Changed 10 years ago by jordan

cfpp2p, regarding the crash, can you get a crash report so that the development team can see what was happening when the crash occurred?

comment:3 Changed 10 years ago by alex73

I didn't see any crashes. May be there are some records in log ? Where can I find transmission's log on MacOS ?

comment:4 Changed 10 years ago by livings124

In Console.app, Show Log List and find at the Transmission crash log in there.

comment:5 Changed 10 years ago by alex73

Thanks, livings124. I found only old crash log(not corresponded with this bug).

So, there are no any crash reports and nothing interesting in system.og for this bug in my box.

comment:6 Changed 10 years ago by cfpp2p

oops... I see that crash was not transmission but memory and virtual memory (swap) problem as below:

(and thttpd sever issue?)

.

Oct 17 10:58:22 (none) user.err kernel: Out of Memory: Killed process 1031 (transmission-da).

Oct 17 10:58:30 (none) user.err kernel: Out of Memory: Killed process 1032 (transmission-da).

Oct 17 10:58:30 (none) user.err kernel: Out of Memory: Killed process 1033 (transmission-da).

Oct 17 10:58:30 (none) user.err kernel: Out of Memory: Killed process 1034 (transmission-da).

Oct 17 10:58:30 (none) user.err kernel: Out of Memory: Killed process 576 (thttpd).

Oct 17 10:58:30 (none) user.warn kernel: VM: killing process transmission-da

Oct 17 10:58:30 (none) user.warn kernel: VM: killing process transmission-da

Oct 17 10:58:30 (none) user.err kernel: Out of Memory: Killed process 581 (thttpd).

.

never has transmission caused this for me otherwise.

Changed 10 years ago by cfpp2p

Changed 10 years ago by cfpp2p

comment:7 Changed 10 years ago by cfpp2p

I recreate torrent so no redirection (used redirected address directly) and still same result, so seems to be nothing to do with redirection. try these torrents...

also from direct http: ubuntuone.com/15o0mrBxlts12zbUo303gC

firefox downloads file: t1

ie explore downloads file: 15o0mrBxlts12zbUo303gC

wget from my linux box: 15o0mrBxlts12zbUo303gC

so what goes I don't know...

comment:8 Changed 10 years ago by alex73

Yes, seems to the same issue when webseed contains link to some http file with other name name. For example, file can be named as "linux.iso", but webseed can be linked to "http://myserver/linux-1.01.iso". It will produce the same issue.

comment:9 Changed 10 years ago by cfpp2p

  • Resolution set to fixed
  • Status changed from new to closed

fixed in r13112

t1.torrent now stops OK and/or will download 100%

note pause/stop of webseed torrent can be slow as it seems a wait until each currently incomplete block is complete before so. This is also related to #1079

comment:10 Changed 10 years ago by livings124

  • Milestone changed from None Set to 2.50

comment:11 follow-up: Changed 10 years ago by alex73

Hi, guys !

Thank you very much for fix it. Could you check also http://alex73.byethost14.com/tr/Ubuntu-11.04.torrent with 2.50 version(I didn't find nightly builds of transmission) ? It contains directory+redirecting.

WBR, Alex.

comment:12 in reply to: ↑ 11 Changed 10 years ago by cfpp2p

Replying to alex73:

Hi, guys !

Thank you very much for fix it. Could you check also http://alex73.byethost14.com/tr/Ubuntu-11.04.torrent with 2.50 version(I didn't find nightly builds of transmission) ? It contains directory+redirecting.

WBR, Alex.

this downloaded a couple of 700 MB .iso from webseed only. worked like a charm. No problems whatsoever.

Transmission 2.42+ (13112)

alt-mac64.iso

desk-mac64.iso

comment:13 Changed 10 years ago by cfpp2p

Alex...

ALSO:

note that pause/stop of webseed torrent can be slow as it seems a wait until each currently incomplete block is complete before so. This is also related to #1079. The bigger the piece size the longer it may take, especially if there are a few incomplete pieces at once.

if you look at inspector

Ubuntu-11.04
Activity
Have:
1.34 GB of 1.35 GB (99.3%), 1.57 MB Unverified

when the Unverified reaches 0 pause/stop will occur, this can take a few minutes as there could be a few pieces yet to complete (4 MB pieces for this Ubuntu-11.04.torrent)

comment:14 Changed 10 years ago by cfpp2p

Great job by the transmission developers! Tested with three levels deep redirection AND link to final file name not the same as what to download, worked perfectly. This is something some other clients can not do.

Bandwidth among concurrent torrents is shaped properly (although issue #1079 will still affect those webseeding), other clients somewhat lax on bandwidth limiting anyways.

so.... transmissionbt !!!!!!!!!!!!

:) ;) :)

Note: See TracTickets for help on using tickets.