Opened 14 years ago

Closed 14 years ago

Last modified 14 years ago

#458 closed Bug (fixed)

Need to use O_LARGEFILE

Reported by: charles Owned by: charles
Priority: Normal Milestone: 0.93
Component: libtransmission Version: 0.92
Severity: Normal Keywords:
Cc:

Description

reported by harik in the forums:

forum/viewforum.php?f=4&sid=336870547db6b9054c7802b60dd70312

On 32 bit POSIX, you're opening files without O_LARGEFILE - this means things like the knoppix live-DVD cannot be downloaded.

And, I'm willing to hazard a guess that there's probably some inconsistancy with int vs size_t in the file code as well.

Secondly, transmission-daemon can't seem to seed a file. If I create a torrent, place the file in the download directory, then -remote -a filename.torrent, it starts at 0% and tries to download it. Rather useless, I'd say.

I've added O_LARGEFILE to the fdlimit.c open() statement, and it can successfully open DVD images now, but it still craps out.

edit: Looks like it can't handle checking a large file, so it fails. Smaller files seem to work. (README in the same torrent) So it's all down to large file support.

Change History (4)

comment:1 Changed 14 years ago by charles

  • Milestone changed from None Set to 1.0

comment:2 Changed 14 years ago by charles

  • Status changed from new to assigned

comment:3 Changed 14 years ago by charles

  • Resolution set to fixed
  • Status changed from assigned to closed

We now use O_LARGEFILE for opening files, and one user on an older 32-bit machine has confirmed that it works for large iso files. He reported no problems with checking, so I'm not sure if there is still an issue there or not. Please re-open the ticket if you're still seeing a problem in svn trunk.

comment:4 Changed 14 years ago by charles

  • Milestone changed from 1.0 to 0.93
Note: See TracTickets for help on using tickets.