Opened 11 years ago

Closed 11 years ago

#4584 closed Bug (duplicate)

Using 3rd party components

Reported by: Zveroy Owned by:
Priority: Normal Milestone: None Set
Component: Web Client Version: 2.40
Severity: Normal Keywords:
Cc:

Description

Just now I awared that Web Client require jQuery from Google API's. What if I work in isolated network environment and doesn't have access to Internet resources? Maybe better to ship jQuery within Transmission Web Client (Transmission and jQuery have the same license anyway)?

Also Google can track which sites require jQuery by Referer HTTP header. Moreover Google can determine where Transmission Web Client if used default port number. I don't like it.

Change History (1)

comment:1 Changed 11 years ago by jordan

  • Resolution set to duplicate
  • Status changed from new to closed
  • Version changed from 2.41+ to 2.40

Thanks for reporting this issue and helping to make Transmission better. This particular bug has already been reported and is a duplicate of bug #4548, so it is being marked as such. Any further discussion regarding the bug should occur in the other report. Thank you!

Note: See TracTickets for help on using tickets.